Since I installed EasyTag on my Arch Linux several other programs use EasyTag instead of Nautilus as filebrowser.

For example, Firefox starts EasyTag if I click on "open containing folder".

Where can I set Nautilus as my "standard file browser"?

up vote 7 down vote accepted

You can define the default file browser by editing the file ~/.local/share/applications/mimeapps.list. Open this file and change the line inode/directory as follow

inode/directory=nautilus.desktop;

If this doesn't work, you should change the filemanager in the file

/usr/share/applications/mimeinfo.cache

by adding (or updating) this line

inode/directory=nautilus.desktop
  • 1
    Yeah looks like easytag corrupted the inode/diectoryline in mimeinfo.cache: inode/directory=easytag.desktop;org.gnome.Nautilus.desktop; Was able to fix it, thx! – rockZ Dec 30 '16 at 21:35
  • It depends on factors that I cannot state, but in some cases the file manager only needs to be present (mentioned) after inode/directory=, even on the last position, no matter if others are also listed there and in what order. In case it doesn't work, one should try to put it there first, while keeping others. If this still doesn't work, it may be necessary to remove at least the culprit that takes over if not all other programs mentioned there except the file manager. – cipricus Jan 11 '17 at 22:34
  • @iBlink - multiple programs listed there shouldn't be a problem, but sometimes is. Have you tried by just putting nautilus first? -- Keeping other programs there (like easytag or media players) may be useful as it adds them to the 'open with' context menu as an option for folders – cipricus Jan 11 '17 at 23:10
  • @cipricus Ah multiple lines are for the open as context menu? Nice to knew since easytag somehow overwrites my changes all the time. I just add another line with inode/directory. Thanks – rockZ Jan 12 '17 at 15:26
  • How to avoid the problem entirely: unix.stackexchange.com/q/336982/32012 – cipricus Jan 12 '17 at 21:40

You can find a comprehensive description of setting up default applications here in the according Arch wiki article.

For your specific case, you edit ~/.config/mimeapps.list and add a new line with inode/directory=nautilus.desktop to the section [Default Applications].

The file should look similar to the following one:

[Default Applications]
text/plain=SciTE.desktop 
text/x-tex=texmaker.desktop 
inode/directory=nautilus.desktop
  • That worked form me I could't find the folder in the accepted answer – l.g.karolos Sep 8 '17 at 15:31
  • 1
    The file ~/.local/share/applications/mimeapps.list` is deprecated (I posted a comment about that to the accepted answer). – Marcus Sep 8 '17 at 15:38

The following command solved this problem in arch linux:

xdg-mime default nautilus.desktop inode/directory

(Source: Arch Forums)

  • In my case the cache was the problem so I edited the file /usr/share/applications/mimeinfo.cache "with sudo" – SergioAraujo 6 hours ago

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.