1
System:    Host: MyComputer Kernel: 4.8.14-gnu-1 x86_64 (64 bit)
           Desktop: LXQt Distro: Parabola GNU/Linux-libre  

There are three places where my computer wants me to use qwerty input.

  • EFI Boot Shell
  • Decrypting my root partition.
  • Display manager sddm.

I would like to able to change all three to dvorak.

0

EFI Boot Shell

Talk to your BIOS vendor. Bring $$$. Or, more likely, $$,$$$.

Decrypting my root partition.

Display manager sddm.

Run this:

localectl set-x11-keymap us pc104 ,dvorak grp:alt_shift_toggle

Then add the keymap hook to mkinitcpio and rerun to generate an initramfs that sets the keymap early in the boot process.

Alternatively, just use QWERTY like the rest of us. If you really want to use Dvorak, this is just the tip of the iceberg: you will soon have to reconfigure editors, IDEs, video players, etc, and it will be a huge time sink, guaranteed.

3
  • 2
    I own a typematrix keyboard with dvorak layout since 2010. It's the only keyboard and layout I took the effort to learn touch typing with. I never had problems with the ones you listed. Setting the keymap was enough for those.
    – Folaht
    Dec 28 '16 at 4:24
  • 2
    I'm a long time Dvorak user too. I use the layout on all my devices. Never had any problem other than in some odd game (and I'm no big gamer). Never had to do much configuring to get it working in Windows, Unix, macOS, Android, and never ever on a per-program basis as you allude to.
    – Kusalananda
    Dec 28 '16 at 15:10
  • @Folatt Well, if you leave the shortcuts to be the same characters as in QWERTY that will work. But a lot of times shortcuts are designed to be usable with the left hand only, so you can mouse at the same time. Thus some Dvorak users prefer to reconfigure shortcuts as well; but if using both hands does not bother you that doesn't apply. Dec 28 '16 at 16:39
2

lxqt

Start|Preferences|LXQT Settings|Keyboard and Mouse|Keyboard Layout
English (US)|English (Dvorak)
TypeMatrix EZ-Reach 2030 USB

sddm

echo "KEYMAP=dvorak" | sudo tee /etc/vconsole.conf
sudo localectl --no-convert set-x11-keymap us tm2030USB dvorak grp:alt_shift_toggle
echo "setxkbmap -model tm2030USB -layout us -variant dvorak -option grp:alt_shift_toggle" | sudo tee -a /usr/share/sddm/scripts/Xsetup

sd-encrypt

nano /etc/mkinitprio.conf

Add sd-vconsole to HOOKS="...

Then do:

sudo mkinitcpio -p linux-libre

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.