1

[The other duplicate threads didn't help, so opening a news one]

I try to mount remote folder and get error like this:

sanjarbek@laptop:~$ sshfs -o sshfs_debug sshd@192.168.1.2:/remote/path /local/path/ 
SSHFS version 2.5
read: Connection reset by peer

I can login to the server like this:

ssh -oHostKeyAlgorithms=+ssh-dss sshd@192.168.1.2

and it works.

The user is in the fuse group:

sanjarbek@laptop:~$ grep fuse /etc/group
fuse:x:1002:sanjarbek

Also:

sanjarbek@laptop:~$ ll /etc/fuse.conf
-rw-r--r-- 1 root fuse 280 Jun 20  2014 /etc/fuse.conf

Does anyone have an idea?

closed as unclear what you're asking by Gilles, grochmal, Anthon, GAD3R, Rui F Ribeiro Dec 27 '16 at 12:25

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Please add the debug information generated by the above command. – schaiba Dec 26 '16 at 19:55
  • 3
    Possible duplicate: unix.stackexchange.com/questions/316277/… – Jakuje Dec 26 '16 at 20:29
  • @schaiba can you tell how to get it? I supplied -o sshfs_debug option, but it only provides the version of sshfs – Sanjarbek Hudaiberdiev Dec 26 '16 at 20:37
  • @Jakuje Thank you. But it is not what I asked here. There, it seems to be about ssh, and adding dss as algorithm. – Sanjarbek Hudaiberdiev Dec 26 '16 at 20:38
2

Create a ~/.ssh/config with the content

Host 192.168.1.2
    HostKeyAlgorithms=+ssh-dss

It is the effective alternative to the thing you did on the command line (ssh -oHostKeyAlgorithms=+ssh-dss sshd@192.168.1.2).

Or generate and set up a new key pair (DSA keys are no longer recommended).

  • Great! Thank you. The ssh now works without explicitly stating the ssh-dss. – Sanjarbek Hudaiberdiev Dec 26 '16 at 20:39
  • No, actually this was the solution, apparently. After a restart the sshfs works now. Thanks @Jakuje. – Sanjarbek Hudaiberdiev Dec 26 '16 at 21:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.