27

From here I understand that to disable Ctrl+S the stty -ixon command can be used and it works, but as soon as I close the terminal and open another I have to re-enter the command.

To permanently disable Ctrl+S I have made a startup.sh that contains the stty -ixon command and run it with crontab at @reboot but it does not work.

So what will be the solution to permanently disable Ctrl+S?

  • 1
    Reminder: if you hit CTRL+S by mistake, you can use CTRL+Q to restore data flow from the terminal. – jjmontes Dec 26 '16 at 14:15
  • 4
    The reason your startup.sh does not work, but the accepted answer does work, is that it has to be done every time a new (pseudo)terminal is activated. – zwol Dec 27 '16 at 4:20
42

To disable Ctrl-s permanently in terminal just add this line at the end of your .bashrc script (generally in your home directory)

stty -ixon
  • a small explanation of what it does would be nice – GoTTimw Apr 26 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.