So after 3 times of trying to install arch Linux, I finally succeeded.

I've noticed that when I was booting from my USB drive, the text size in the terminal was a lot smaller than it is when using the actual installed operating system. I was able to see a lot of text on one line, but now it takes up two or three lines. It's just annoying trying to read "locale" and have the "loc" on the right side of the screen and have "ale" on the left side on the next line.

I don't have a desktop environment yet. I am talking about the text size seen on the virtual terminals, logging in at a TUI login:prompt.

Is there any way that I can make the text size smaller?

  • Which "terminal"? Are you talking about the linux virtual console? If so, you should probably look at installing and running Xorg ... Dec 25, 2016 at 1:29
  • I'm not using a virtual console, I don't have a desktop environment yet. I can only use bash right now.
    – Keira
    Dec 25, 2016 at 2:41
  • 1
    If you don't have a "desktop environment", you are using the Linux virtual console. The font size can only be controlled if you use KMS (otherwise it is up to the BIOS to render things). So load the appropriate KMS driver for your video card to get better virtual console resolution. Dec 25, 2016 at 3:15

2 Answers 2


You might also want to try changing the display resolution set at boot in your /etc/defaults.grub file, esp. if you have the opposite problem and have 3cm tall characters.

It is probably best if your screen is at native resolution, but sometimes this causes problems if you have two screens with different resolutions attached.

The line you want is the GRUB_GFXPAYLOAD. Sometimes you can get by with GRUB_GFXMODE="auto" but sometimes you need to just set it to the same at the GFXPAYLOAD.

You will need to do that as root (e.g. su, sudo or log-in as root) and then (as root) update your grub.cfg.

I am not sure what Arch uses to update grub after you do this, but with openSUSE it is grub2-mkconfig -o /boot/grub2/grub.cfg and the Ubuntu types seem to like update-grub. It is insanely maddening to forget to do this step, as nothing will be changed when you reboot. (Esp. if you keep forgetting to do it and cannot figure out why no combination of the two settings does anything!)


Arch article

The FONT variable in /etc/vconsole.conf is used to set the font at boot, persistently for all consoles. See man 5 vconsole.conf for details.

For displaying characters such as Č, ž, đ, š or Ł, ę, ą, ś using the font lat2-16.psfu.gz:



It means that second part of ISO/IEC 8859 characters are used with size 16. You can change font size using other values (e.g. lat2-08). For the regions determined by 8859 specification, look at the Wikipedia table.

  • OP's question was about a different aspect, which was mentioned in the comments. Dec 25, 2016 at 11:28
  • @ThomasDickey OP says he's using the virtual terminal, then in the comment while saying he doesn't, he confirmed he uses the virtual console/Getty. So what I posted applies.
    – psarossy
    Dec 25, 2016 at 11:34
  • The available fonts range in size less than "a lot". If you test that, you'll notice. Dec 25, 2016 at 11:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .