-1

On my Arch, root can directly login via tty without password. However, for normal users, password is mandatory.

So, How to disable the auto-login of root on tty.

  • You are confusing answerers by talking about automatic login when you seem rather to have a passwordless superuser account or something like the setup in unix.stackexchange.com/questions/184486 . Explain in your question what prompts you see and have to respond to. Do you see a login: prompt and have to explicitly answer root? Do you see a password: prompt? – JdeBP Dec 24 '16 at 22:41
0

Maybe you have a /usr/lib/systemd/system/getty@ttyN.service?

The context looks like this:

ExecStart=-/sbin/agetty --noclear -a root %I 38400 linux 

You just need to delete or disable this service.

  • It would normally have been a good idea to validate details through comments (I know you can't comment yet) but your answer seems like a likely possibility which could help others as well. It might be a tad better if you provided the command to disable the service. – Julie Pelletier Dec 24 '16 at 17:32
  • Thanks for advice, I am a newbee and I will pay attention to it later. – Barathrum Dec 24 '16 at 17:42
  • Disabling the login service entirely is not what the questioner asked for at all. – JdeBP Dec 24 '16 at 22:24
  • this kinda works, bit disabling is a bad idea because after reboot, you wont even be able to reach the tty again, requiring usb live boot tools. – Blauhirn Jan 10 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.