0

When I try to install cloudera-manager-agent 5.7 from an .rpm I get an error. The error says that a dependency has not been met because yum could not find libpython2.6.so.1.0(64bit). I would expect Python 2.7 to be supported with Cloudera 5.7. Cloudera 5.7 is new, and Python 2.6 is old.

I am using Python 2.7.5 on CentOS 7.2 Should I downgrade to Python 2.6? I'm concerned that many things will stop working. How do I get this dependency (related to Python 2.6) to be met to install Cloudera-Manager-Agent? I think this file would need to be registered with the yum package manager. But I need to get the file on the OS first. However, I do not know if something related to Python 2.6 can work with Python 2.7.

0

Actuall how many application on your centos 7.2 depended on python 2.7? You can not do downgrade when python 2.7 was default from centos 7.2. My suggestion : downgrade centos 7.2 to centos 6.8.Or you want to install python 2.6 manually and download it from rpm.pbone.net.And you should remove python 2.7 from centos 7.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.