0

I have a usb drive. It mounts as "ro." When I mount -o "remount,rw" I see this in dmesg.

hfsplus: filesystem was not cleanly unmounted, running fsck.hfsplus is recommended. leaving read-only.

The verbose flag (-v),mount -v` doesn't tell me anything more. It actually says the mount worked,

mount: /dev/sdb1 mounted on /media/ecarroll/myDevice.

Running fsck.hfsplus on the block device, gets me

$ sudo fsck.hfsplus /dev/sdb1 
** /dev/sdb1
** Checking HFS Plus volume.
** Checking Extents Overflow file.
** Checking Catalog file.
** Checking Catalog hierarchy.
** Checking Extended Attributes file.
** Checking volume bitmap.
** Checking volume information.
** The volume myDevice appears to be OK.

I wanted this to be clear in the above, but the -o remount,force also doesn't work.

sudo fsck.hfsplus -f /dev/sdb1; sudo mount -o remount,force,rw /dev/sdb1 ; sudo dmesg -c
** /dev/sdb1
** Checking HFS Plus volume.
** Checking Extents Overflow file.
** Checking Catalog file.
** Checking Catalog hierarchy.
** Checking Extended Attributes file.
** Checking volume bitmap.
** Checking volume information.
** The volume 2819010011 appears to be OK.
[97230.751669] hfsplus: filesystem was not cleanly unmounted, running fsck.hfsplus is recommended.  leaving read-only.

How do I mount this device read-write?

0

After you get

** The volume myDevice appears to be OK.

You can unplug the device, and plug it back in and automount will take care of it with -o rw. I'm unaware of what it takes to get -o rw to work, after mount thinks the device is dirty, without pulling it and plugging it back in.

  • This does not explain or solve the issue at all. I'm under the impression that you're facing a HFS bug with the clean bit but I've never investigated such issues before. – Julie Pelletier Dec 22 '16 at 3:51
  • You would think so, but after putzing with this, and with -y, and with other options I'm inclined to think that mount just reread the dirty bit on -o remount. – Evan Carroll Dec 22 '16 at 4:04
  • I understand. That's why I think it's a bug with the FS or partition driver since it doesn't happen on other partition types that I'm aware of. – Julie Pelletier Dec 22 '16 at 4:38
-1

It seems some one has already experience the issue take a look here:

https://askubuntu.com/questions/332315/how-to-read-and-write-hfs-journaled-external-hdd-in-ubuntu-without-access-to-os

Here is an extract of the answer:

First, make sure that you have hfsprogs installed. Example installation >command:

sudo apt-get install hfsprogs

Next, mount or remount the HFS+ drive; commands need to be as follows:

sudo mount -t hfsplus -o force,rw /dev/sdXY /media/mntpoint

or

sudo mount -t hfsplus -o remount,force,rw /mount/point ...

Finally, if the drive was improperly unmounted or has otherwise become >partially corrupted run fsck.hfsplus ... as such:

sudo fsck.hfsplus -f /dev/sdXY

Also there is interesting information here for linux:

https://help.ubuntu.com/community/hfsplus

  • I did fsck.hfsplus -f /dev/sdXY, but mount -o remount,rw did not work. – Evan Carroll Dec 22 '16 at 4:37
  • ok but did you give a try adding the "force" parameter like this ? – Matthieu Ducorps Dec 22 '16 at 4:55
  • sudo mount -t hfsplus -o force,rw /dev/sdXY /media/mntpoint – Matthieu Ducorps Dec 22 '16 at 4:56
  • Even if the force option overrode the issue, it wouldn't be a good solution to the problem. – Julie Pelletier Dec 22 '16 at 16:08
  • @JuliePelletier I'm interested to understand why ? – Matthieu Ducorps Dec 24 '16 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.