0

I'm working on a Raspberry Pi project on a Zero board. I'd be so happy if I could write a sizable number of files from a Windows or MAC laptop onto the microSD card that I plug into my Pi project, and then my installation of Raspbian could read those files. I'm pretty unfamiliar with Linux and partitioning, but after some research, I came to the conclusion that a FAT32 partition was what I needed (I would prefer not to use my /boot partition as the common location). I took the following steps to make a large FAT32 partition on a fresh install of Raspbian:

  1. Reformatted my microSD card with SDFormatter, a tool found online
  2. Copied a downloaded image of Raspbian (the oldest version of Jessie) onto my microSD card using Win32SDImager
  3. Followed this guide to the letter, with no unexpected results bar the fact that dosfstools was already installed
  4. Turned off my Pi, removed my microSD card, and tried to read it from my Windows laptop

When I read the microSD card on my Windows laptop, I only see the /boot filesystem, though I get a note that there is something wrong with the drive. When I click that notice, I'm given the option to scan. Windows notified me that it identified the errors, but I'm hesitant about allowing Windows to try to repair those errors.

Here are the results of sudo fdisk -l as well as an attempt to mount the filesystem with sudo mount /dev/mmcblock0p3 /mnt/storage:

Partitioning and mounting results

0

Instead of mkfs.msdos better use mkfs.vfat so the command would look like

sudo mkfs.vfat /dev/sdaX

where X would be the right number for your partition.

That should get the work done!

  • I tried that on the microSD card that was used as described above, and I got the following error: – Andy Pollino Dec 22 '16 at 0:53
  • just the dash ? – Julian Berger Dec 22 '16 at 0:55
  • Goofed by pressing enter instead of shift enter :P – Andy Pollino Dec 22 '16 at 0:59
  • I tried that on the microSD card that was used as described above, and I got the following error: /dev/sda3: No such file or directory I replaced /dev/sda3 with /dev/mmcblk0p3 (my partition name from fdisk -l), and I got the following error: mkfs.vfat: /dev/mmcblk0p3 contains a mounted filesystem. I unmounted it with 'sudo umount /dev/mmcblk0p3' and then did your command modified for my partition. When I plugged it into my laptop, I still only see my /root directory, but no error notification. Do I need to do this on a fresh install? Would I omit the step of editing /etc/fstab? – Andy Pollino Dec 22 '16 at 1:00
  • I just learned, that windows doesn't like multiple partitions on sdcards according to superuser.com/questions/975900/… – Julian Berger Dec 22 '16 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.