2

I've recently built my first PC and got it all working (yay!) except for the USB 3.0 ports. I don't think any of the USB 3.0 ones are working, there are some in the MB/back and also a couple at the front, I did plug in the USB 3.0 wire from the case to the mb, and made sure the USB 3.0 option is enabled in BIOS. I can't update the mb drivers as there are only options for windows on the msi site. MB is MSI 970 Gaming.

If I go into BIOS, I can see the devices I have plugged into the USB 3.0's, but if I try to see them through the command line once booted, they aren't there.

I had the same problem. Resolved it by adding in /etc/default/grub:

GRUB_CMDLINE_LINUX="iommu=soft"

Then sudo update-grub, reboot and voilà!

Just to clarify, I'd like to get to the point of plugging in a USB device (mainly into the front ports) and have them recognized. I'm not too concerned about whether they function as USB version 2 or 3 right now, so long as they work.

1

Use whatever text editor to edit the following file as root:

/etc/default/grub

The editor will open showing you the contents of grub configuration file. Search for this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change the line by adding iommu=soft and now the line will look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=soft"

Save the file and exit text editor.

Now, type to the terminal:

sudo update-grub

Finally, reboot your PC and the recommended change takes effect. Hopefully all your USB 3 ports are working now.

Besides the recommendation you were seeking help on I would look in your BIOS and carefully examine all USB related options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.