2

I am trying to connect over serial cable from ubuntu 12.04 to an embedded linux device for which uname -a returns:

Linux demosystem 3.10.17-1.0.0_ga+yocto+ga29b925 #1 SMP Mon Jul 6 21:50:27 PDT 2015 armv7l GNU/Linux

I have minicom setup to connect ttyUSB0 from my laptop to a serial port labeled CPU Serial on the device, which corresponds to ttymxc1.

Instructions I was given for this connection was:

(115200, 8, N, 1, No Flow )

Which is how I have minicom setup. (No Hardware and No Software Flow Control)

All other minicom settings were left default.

I have an ssh connection to the embedded device, and when I run minicom on my laptop, I run the command from the device:

echo "hello" > /dev/ttymxc1

This results in garbage text coming up on minicom, so I know they are connected somehow, but I don't know what setting to check/change in order to be able to get the text correctly transferred.

EDIT: Also the command on the device: root@demosystem:~# dmesg | grep console returns: [ 0.000000] Kernel command line: console=ttymxc1,115200 root=/dev/sda1 rootfstype=ext4 rootwait rw video=mxcfb0:dev=adv739x,BT656-NTSC,if=BT656,fbpix=RGB565,bpp=32 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off cma=384M galcore.gpu3DMinClock=3 [ 1.791357] console [ttymxc1] enabled

  • Are you getting the same number of characters, like they're a different encoding, or does it look more like garbage (like a protocol mismatch)? I'd verify the baud rate on both sides and try something like cat /dev/ttyUSB0 | hexdump -C and compare the output. You may also need to verify you don't need other control lines hooked up on the serial link. – melds Dec 21 '16 at 20:21
  • Did you try turning it off and back on again? I've often had problems like this when connecting the serial port to an embedded device when the embedded device was already powered on. Leaving the serial port connected and rebooting the device would fix it. – drewbenn Dec 21 '16 at 20:24
  • @melds Sorry away from the laptop now but I'm nearly sure the same amount of characters show up each time – kujosHeist Dec 21 '16 at 20:44
  • @drewbenn I've tried rebooting but usually I disconnect the port, il give this a try too – kujosHeist Dec 21 '16 at 20:45
  • try echo "hello" > /dev/console ... – Murray Jensen Dec 24 '16 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.