1

I'm trying to set up a Linux system (Debian 8.5, kernel 3.16.36-1+deb8u2, 64-bit) using systemd-networkd to configure the network interface. I need segmentation offload disabled, so I set up my link file like this:

# /etc/systemd/network/0-lan_user.link
[Match]
MACAddress=00:11:22:33:44:55
[Link]
Name=lan_user
TCPSegmentationOffload=false
GenericSegmentationOffload=false

But it doesn't seem to apply:

ethtool -k lan_user | grep segmentation-offload
tcp-segmentation-offload: on
generic-segmentation-offload: on

If it makes a difference, this is a vmxnet3 adapter (under ESXi, of course).

What am I doing wrong?

1 Answer 1

1

The systemd version in Debian 8 is 215 at the moment (source), but the various Offload options in .link have only been added in version 232:

UDP Segmentation Offload, TCP Segmentation Offload, Generic
Segmentation Offload, Generic Receive Offload, Large Receive Offload
can be enabled and disabled using the new UDPSegmentationOffload=,
TCPSegmentationOffload=, GenericSegmentationOffload=,
GenericReceiveOffload=, LargeReceiveOffload= options in the
[Link] section of .link files.

(systemd changelog)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .