0

I'm trying to install libstdc++-4.4.4-13.el6.i686.rpm but it says newer version of this package is already installed.

[root@isoft Downloads]# rpm -ivh libstdc++-4.4.4-13.el6.i686.rpm
warning: libstdc++-4.4.4-13.el6.i686.rpm: Header V4 DSA/SHA1 Signature, key ID 192a7d7d: NOKEY
Preparing...                ########################################### [100%]
package libstdc++-4.4.7-17.el6.x86_64 (which is newer than libstdc++-4.4.4-13.el6.i686) is already installed*

Even i cannot uninstall libstdc++-4.4.7-17.el6.x86_64.

[root@isoft yum.repos.d]# yum install libstdc++-4.4.6-4.el6.i686
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libstdc++.i686 0:4.4.6-4.el6 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for libstdc++ which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libstdc++ of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libstdc++.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of libstdc++ installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of libstdc++ installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: libstdc++-4.4.6-4.el6.i686 != libstdc++-4.4.7-17.el6.x86_64

any one has thoughts to resolve this error.

  • Sounds like an XY problem to me. Why would you want the very old 4.4.4 version ? – Dani_l Dec 22 '16 at 16:16
0

You should run

yum downgrade libstdc++

and solved dependencies.Hopefully repos still got libstdc++ 4.4.4-13 that you wanted. @anthon and @sam should improve reading skill. His problem was installing lower version of libstdc++ without removed higher version of libstdc++.I showed him how to install and remove installed packages. Even he cant install lower version of libstdc++ thru yum because of dependencies problem.Anything wrong with my answer?

0

when you get this kind of issue, can enter this command

package-cleanup --dupes

this show you the packets that you need remove (duplicates and oldies versions)of the system to can install the packets with the architecture that the repo want install, then you'll need to start again the installation.

Note: this problem is reference that system can't install some packet's architecture because there one old same packet with other architecture. this mean that need quit the duplicates and oldies packets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.