4

I have barebones raspbian, i.e. basically Debian 8, with systemd and no X. I removed dbus with "apt-get remove dbus". It deinstalled cleanly, with no apparent programs depending on it. Now, whenever I login on the console after the motd I get this line:

Failed to get D-Bus connection: No such file or directory

What's the source of that message, and how can I make it stop? Must be something somewhere in /etc I can set, right?

It looks like systemd still thinks there is a dbus. There is still a dbus.service which I manually disabled with systemctl, just to be sure. It complained (inserv warning current start runlevel(s) (empty) of script dbus overrides LSB defaults ....) but, all my services do seem normal; I don't know for sure. Running "systemctl start anythinghere" as non-root produces the same error. So user-level privilege systemd, whatever it is called, appears to be the source but I don't have systemd-logind running on my system, and I don't understand how /bin/login is calling systemd.

  • Systemd is very likely tightly integrated with DBus. If you want to get rid of both, have a look at Devuan, though I don't think there's something ready-made for the RaspPi. – dirkt Dec 21 '16 at 8:38
0

Maybe some package only recommends the dbus package, you could try to run apt-get rdepends --installed dbus to see if anything has still references to it

  • Thanks, didn't think of that! I'm As you meant apt-cache rdepends --installed dbus. There was still a libdbus-1-3 installed on thtis system. Removing that didn't help. The only other package is systemd, which I confirms my initial suspicion. – Tibinah Dec 21 '16 at 15:48
  • What about libpam-systemd? – Bigon Dec 21 '16 at 21:50
0

The culprit is service ssh status executed by /etc/profile.d/sshpasswd.sh. The funny part is how there is no openssh installed on the system.

0

This command helped remove orphan packages:

apt-get autoremove

Might write your own Kernel to remove services and daemons from the source: take out anything ssh, dbus, etc.

My fun has been taking Mint 17 to the bare bones: firefox with flash, sauerbraten and wesnoth, and to play DVDs.

No more Python, Gnome, or GTK. Now, working to remove dbus. Went from 2,000 packages installed to only 775. The computer is more responsive and uses 20% less CPU, but ping still around 200.

My motivation for this is to simplify Linux Mint and remove all the red tape it is wrapped in. I like multimedia support and excellent installation with Mint, but feel we've digressed a bit on the size of the install and the 'CPU and HDD are infinite' philosophy.

  • Careful with the custom kernel. Keep the default handy as backup until you're absolutely sure that you didn't need the driver you removed. Not everything is named obviously and it's really embarrassing to remote reboot a system only to find out you'd forgotten the driver for its HDD controller... – Shadur Jun 30 '17 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.