I'm using Vagrant 1.8.1 on Ubuntu 16.04 hosting Debian Jessie.

I've set up an account with Atlas, logged in from the terminal, execute:

vagrant share

And I'm getting the help screen with the exit code 1.

There seems to be an open issue at GitHub here from January '16. I've tried to troubleshoot myself with

vagrant up --debug 2>log

But nothing appears in the log when I do share.

A possibly weird thing is that the share command is missing among the commands at /usr/share/vagrant/plugins/commands. It's also missing in the listing produced with:

vagrant list-commands

It's also missing in the same folder at GitHub and I don't see it there in the GitHub history.

It's not missing in the documentation though.

I don't know Ruby, so there's not much point in reading /usr/bin/vagrant, which I did anyhow.


In reply to @jayhendren.

$ vagrant plugin install vagrant-share
Installing the 'vagrant-share' plugin. This can take a few minutes...
/usr/lib/ruby/2.3.0/rubygems/specification.rb:946:in `all=': undefined method `group_by' for nil:NilClass (NoMethodError)
    from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:275:in `with_isolated_gem'
    from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:231:in `internal_install'
    from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:102:in `install'
    from /usr/lib/ruby/vendor_ruby/vagrant/plugin/manager.rb:62:in `block in install_plugin'
    from /usr/lib/ruby/vendor_ruby/vagrant/plugin/manager.rb:72:in `install_plugin'
    from /usr/share/vagrant/plugins/commands/plugin/action/install_gem.rb:37:in `call'
    from /usr/lib/ruby/vendor_ruby/vagrant/action/warden.rb:34:in `call'
    from /usr/lib/ruby/vendor_ruby/vagrant/action/builder.rb:116:in `call'
    from /usr/lib/ruby/vendor_ruby/vagrant/action/runner.rb:66:in `block in run'
    from /usr/lib/ruby/vendor_ruby/vagrant/util/busy.rb:19:in `busy'
    from /usr/lib/ruby/vendor_ruby/vagrant/action/runner.rb:66:in `run'
    from /usr/share/vagrant/plugins/commands/plugin/command/base.rb:14:in `action'
    from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:32:in `block in execute'
    from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:31:in `each'
    from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:31:in `execute'
    from /usr/share/vagrant/plugins/commands/plugin/command/root.rb:56:in `execute'
    from /usr/lib/ruby/vendor_ruby/vagrant/cli.rb:42:in `execute'
    from /usr/lib/ruby/vendor_ruby/vagrant/environment.rb:268:in `cli'
    from /usr/bin/vagrant:173:in `<main>'

The same with sudo.

And I get the same error when I try to install any other plugin. I couldn't find vagrant-share listed anywhere as available anywhere. Unlike this one and called so:

$ vagrant plugin install vagrant-netinfo

You need to install the vagrant-share plugin:

[birdsnest ~]% vagrant plugin install vagrant-share
Installing the 'vagrant-share' plugin. This can take a few minutes...
Fetching: vagrant-share-1.1.6.gem (100%)
Installed the plugin 'vagrant-share (1.1.6)'!
[birdsnest ~]% vagrant list-commands
Below is a listing of all available Vagrant commands and a brief
description of what they do.


connect         connect to a remotely shared Vagrant environment


share           share your Vagrant environment with anyone in the world

  • vagrant-share should come by default. Strange! – heemayl Dec 20 '16 at 3:22
  • @heemayl Vagrant Share appears to be an abandoned service (now called Atlas, and free hosting has been axed), so it's not surprising that most Vagrant packages no longer bundle vagrant-share. – jayhendren Dec 20 '16 at 4:22
  • Hmmm, came with my Ubuntu 14.04's recommended one though. +1 – heemayl Dec 20 '16 at 4:31

After I found a similar one and one more, I kicked away the Ubuntu packaged vagrant and got an original one from Vagrant. Easy peasy, now it's ok.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.