1

I just reinstalled ArchLinux on my Thinkpad. I am a bit puzzled that the network-manager-applet only supports WEP encryption for wifi networks.

network-manager-applet

I already installed wpa_supplicant and wireless_tools as suggested elsewhere on the internet.

0 ✓ user@alcor ~ $ pacaur -Qs network
local/libnm-glib 1.4.4-1
    NetworkManager library
local/network-manager-applet 1.4.2-1
    Applet for managing network connections
local/networkmanager 1.4.4-1
    Network connection manager and user applications
local/nm-connection-editor 1.4.2-1
    NetworkManager GUI connection editor and widgets

I'm running ArchLinux with kernel 4.8.13-1-ARCH and the classic Mate Desktop environment in GTK-2 version.

How to enable WPA and WPA2 for the Network Manager Applet?

  • after installing wpa_supplicant you have restart the service and the applet? – user192526 Dec 19 '16 at 19:41
  • Yes. Did a full system reboot meanwhile. – Waqar Lim Dec 19 '16 at 21:04
  • I can only give you a link, because I have no arch <wiki.archlinux.org/index.php/WPA_supplicant – user192526 Dec 20 '16 at 9:22
  • I can't find anything specific about network-manager-applet on that wiki page. wpa-supplicant is installed and enabled. – Waqar Lim Dec 20 '16 at 9:53
0

Ok I was confusing two things: (1) creating new networks with the network-manager-applet only supports unencrypted or WEP encryption, as shown in the screenshot above. (2) Connecting to WPA secured wi-fi networks works with wireless_tools and wpa_supplicant installed.

However, it did not work in my case because I was using the network-manager-applet which was designed for GNOME on a MATE desktop environment. Here is the important snippet from the Arch Wiki:

Troubleshooting

No prompt for password of secured Wi-Fi networks

When trying to connect to a secured Wi-Fi network, no prompt for a password is shown and no connection is established. This happens when no keyring package is installed. An easy solution is to install gnome-keyring. If you want the passwords to be stored in encrypted form, follow GNOME Keyring to set up the gnome-keyring-daemon.

My mate installation was lacking a keyring. Installing gnome-keyring fixed the issue.

$ sudo pacman -S gnome-keyring

I am now able to use the WPA secured wi-fi networks again.

0

nm-applet creates an Ad-hoc connection through that menu.

You might want to create a hotspot connection, and you can do that through "Edit Connections..." nm-applet Editing wifi-test

You will then be able to select WPA & WPA2 Personal on Wi-Fi Security tab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.