1

I have a Beaglebone (Debian) with two network interfaces: eth0, usb0.

  • usb0 is enabled by ifup from the system start (and used by udhcpd later)
  • eth0 is started by wicd when users connects a cable

Here is routng table:

0.0.0.0         192.168.7.1     0.0.0.0         UG    0      0        0 usb0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.7.0     0.0.0.0         255.255.255.252 U     0      0        0 usb0

The routing table does not work, eth0 should be routed via 192.168.0.1 gateway.

How could I make wicd

  • get a gateway via dhcp,
  • set up the gateway (and the route) for its interface.

I can do this in post-connection scripts or statically. I wonder if things can be done simpler via correct configuration of configs like wired-settings.conf?

migrated from serverfault.com Dec 19 '16 at 15:09

This question came from our site for system and network administrators.

1

If you cannot add something for a dynamic interface, you can remove the conflict from the static one. usb0 was statically defined in /etc/network/interfaces It is possible to delete a default gateway for usb0 via post-up, then you get the one from wicd correctly.

iface usb0 inet static
    address 192.168.7.2
    netmask 255.255.255.252
    gateway 192.168.7.1
    post-up route del default dev usb0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.