0

In order to test OS upgrade of a Ubuntu Server 12.04, I cloned it into VirtualBox VM on my workstation. Most things behave the same way and I was able to resolve a few differences. However, there is one problem I haven’t been able to solve yet and cannot find any help on the Web.

The server is used to hold backups of SVN repositories. It is synchronized with the main SVN server using commands like:

svnsync sync https://192.168.3.5/svn/project1

The mentioned IP address belongs to the same server (localhost) and the command works on the server well. I tried changing it to either localhost or the actual IP address of the VM’s network card on the clone, 10.0.2.15. In both cases I am getting errors:

svnsync: OPTIONS of 'https://10.0.2.15/svn/project1': SSL handshake failed: SSL error: An unexpected TLS packet was received. (https://10.0.2.15)

Wget is more verbose:

$ wget https://localhost/svn/project1
--2016-12-19 10:14:39--  https://localhost/svn/project1
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:443... connected.
OpenSSL: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
Unable to establish SSL connection.

However, the original server gives the same result.

How to solve the SSL problem?

0

The problem was caused by an invalid configuration in /etc/apache2/sites-enabled/ssl. Some items were pointing to the original server’s IP address or domain name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.