0

I have configured my system to use the powersave governor for CPU frequency, in order to increase battery life.

However, even after setting it up and verifying that it is active, my cpu frequency is usually quite high, usually 2+ GHz even though cpupower reports the lowest supported frequency is 800MHz.

As I understand it, powersave should be throttling the CPU to its lowest allowed frequency, but it clearly is not doing that. What can I do? Is powersave working properly?

  • What I understood PowerSave CPU Frequency (sleeping mode when CPU didnt do any heavy processing) set on my notebook BIOS.it reduced power usage on CPU.Linux system set reducing harddisk spin and reducing brightness of Display. – supriady Dec 19 '16 at 4:59
  • Can you show us how you concluded that the frequency did not change? You should also keep in mind that reducing the frequency is not the only way to save on CPU power since there is a sleep instruction which lets it rest when there is no demand. You should therefore notice lower temps when that option is selected. – Julie Pelletier Dec 19 '16 at 5:02
  • @JuliePelletier I monitored it using powertop frequency tab. I know that frequency isn't the only thing determining power draw. I just want to make sure that the governor is working properly, – markasoftware Dec 19 '16 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.