0

I'm using 64-bit Linux Mint 18 (Cinnamon 3.0.7). I have PlayOnLinux installed with Microsoft Office 2007 32-bit, which worked flawlessly until now. I can neither print from both Word and Excel, nor save document as PDF. Each time I try to do that, I get an error saying no printer is installed. It used to worked earlier.

I do have one network (WiFi) printer installed - it is Canon Pixma MX885 with linux drivers downloaded and installed from official website. I can print files from linux programs without any problem, as well as other windows apps installed on PlayOnLinux, but Microsoft Office does not detect the printer. What might be the cause? Is there any way to get it working?

0

I've tryed to follow Kaleo's suggestion and scr***wd my linux... It did not fix, mess it all and was hell to get rid of the modifications.

After researching printing files structure etc, I've found a better solution! It seems that some distro don't point to the right printcap file.. So, that's what I did:

First, make sure you have CUPS installed:

 sudo apt-get install cups cups-pdf

then, if you have it, backup original printcap

 sudo mv  /etc/printcap /etc/printcap.bkp

now create a symlink to the CUPS' printcap. In my case it was at /var/run/cups/

ln -s /var/run/cups/printcap /etc/printcap
0

I have had this problem, and installled lpr packages to solve this. See in the directory /etc/printcap, if there is this file, after install package.

My system is: mint mate 64 on core i5 laptop, and I installed the libcups-pdf too, and cups packages in general. I installed playonlinux and then installed office 2007 32 bits.

  • After installing lpr Microsoft Office can see a printer called lp, but neither printing works (nothing happens), nor saving as PDF (File not found error appears). libcups-pdf does not appear in my package manager. Installing lpr also removed package cups-bsd from my computer. – burtek Dec 24 '16 at 23:39
0

Solution is easy, just use Microsoft office 2010 on playonlinux install menu. then browse your MS office 2007 cd or exe on drive and finish installation. Do not use Microsoft office 2007 on playonlinux install menu.. there is bug..

0

Solved the issue on my side (Mint 18.3) just by installing libcups2:386.

sudo apt install libcups2:i386

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.