I have grub installed on /dev/sdb1
I have swap on /dev/sdb2
I have archlinux / on /dev/sdb3
I have windows on /dev/sdb4

When I didn't install windows, the system booted on grub, and then it booted on arch.

Now I've installed windows; first, I couldn't boot on grub at all.

Then, I've chrooted and grub-install, grub-mkconfig, etc.. I've set the /dev/sdb1 to bootable.

Now, it boot to /dev/sdb1, but it show only Windows entry, and when I chroot into arch, I do os-prober, genfstab, etc, it don't want to work... It only show me windows on /dev/sdb4.


I've found the solution ! I don't know if it's the cleanest, but it worked.

I modified grub.cfg with a LiveUSB Linux, and i manually added an entry to the GRUB Menu :D !

Now it works like if the OS Prober detected Arch Linux, but i added it manually.

Thanks to the helpers !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.