3

I've been following a youtube tutorial to install arch linux (using virtual box) and it led me to a problem that i have no clue how to solve. Whenever i try to boot Arch it gets stuck at "reached target Graphical interface". There is no escape from here no matter what i do (i tried ctrl-alt-f2 but it just return in a second). The last thing i did was: sudo systemctl enable lxdm.service (then a reboot). I don't know if that is enough info to solve my problem or not.

PS: a google search shows that many people have had similar problems but all the solutions are impossible to do as i am trapped on the boot screen.

6
  • In your Googling, have you looked for VirtualBox answers, or just answers related to Arch Linux?
    – Wildcard
    Dec 17, 2016 at 6:08
  • 5
    Don't use random youtube tutorials: they are always out-of-date and wrong. Use the official Arch Installation Guide.
    – jasonwryan
    Dec 17, 2016 at 6:16
  • What is your current desktop environment? Try installing and configuring a second one, preferably a lighter one like lxde or lxqt. Due to the bleeding edge nature of arch, it is better to have several availabke alternatives that you can change from display manager. Also you can try sddm for dm, though it is not as light as lxdm.
    – S.C
    Dec 17, 2016 at 9:56
  • You should really not install Arch using a youtube "tutorial", you should try to redo your vm using the official beginner's guide, install openssh and virtualbox-guest-utils (choose dkms when asked). Arch works very well with virtualbox, I even have a RAID0 vm! As for a dm, I prefer lightdm over all others.
    – cylgalad
    Dec 17, 2016 at 10:20
  • 1
    In VirtualBox have you tried disabling nested paging? This has solved the issue for me in the past. However, since recently, the virtualbox-guest-utils (choosing arch), also does not work for me, hangs at the same line, showing the error: Detected Tx Unit Hang
    – NOhs
    Dec 17, 2016 at 20:59

1 Answer 1

1

What worked for me was to uncheck "Enable 3D Acceleration". In VirtualBox go to the machine "Settings" then "Display".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .