Say I have connected with wpa_cli to a network mynetwork:

# wpa_cli 
>set_network 0 ssid "mynetwork"
>set_network 0 psk "SupahSecretPassphrase"
>enable_network 0

How to export this network to a wpa_supplicant configuration file, that is a file containing:


If there is no standard way, I guess I would have to recall ~/.wpa_cli_history


I tried save_config but I always have a FAIL result:

>  save_config

1 Answer 1


You should add update_config=1 to your configuration file , it will give the rights to update it.

there is an example :

edit the /etc/wpa_supplicant/wpa_supplicant_example.conf , add the following lines:


Run wpa_passphrase command to export your configuration to wpa_supplicant_example.conf

wpa_passphrase Your_ssid Your_passphrase >> /etc/wpa_supplicant/wpa_supplicant_example.conf

Save then connect through wpa_cli.

  • Honestly I still get the FAIL error when trying to save_config, following these steps didn't work to me.
    – another
    Feb 10, 2018 at 19:18
  • @roizpi Did you have NetworkManger installed? Did you have a wired connection available to reinstall it later if something went wrong ? If YES remove it.
    – GAD3R
    Feb 10, 2018 at 19:20
  • I haven't networkmanager installed. I have the wired connection yes, and wlan1 seems to have access point associated, but when disconecting the wire, I can't find any host associated with that machine.
    – another
    Feb 10, 2018 at 19:32
  • @roizpi Check the status wpa_cli status disconnect wpa_cli disconnect then try to reconnect. Remove the RJ45 first.
    – GAD3R
    Feb 10, 2018 at 20:57
  • 1
    I made the network work by using your steps, and making a proper configuration of /etc/network/interfaces. Thank you.
    – another
    Feb 10, 2018 at 21:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .