0

I'm trying to install virtualbox guest additions for Kali Linux on Oracle VBox 5 as specified on the kali linux page.

When I run:

apt-get update

apt-get install -y virtualbox-guest-x11

virtualbox-guest-x11 has missing dependency xorg-video-abi-19 which I can't find a way to install.

root@kali:~# apt-get install -y virtualbox-guest-x11
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 virtualbox-guest-x11 : Depends: xorg-video-abi-19
E: Unable to correct problems, you have held broken packages.

root@kali:~# apt-get install -y xorg-video-abi-19
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Package xorg-video-abi-19 is a virtual package provided by:
  xserver-xorg-core 2:1.17.2-1 [Not candidate version]

E: Package 'xorg-video-abi-19' has no installation candidate

Alternatively when I try the procedure described for older distros, I successfully install:

apt-get update && apt-get install -y linux-headers-$(uname -r)

However after running ./VBoxLinuxAdditions.run I get the following:

root@kali:~# ./VBoxLinuxAdditions.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.24 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 5.0.24 of VirtualBox Guest Additions...
Removing existing VirtualBox non-DKMS kernel modules ...done.
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module ...fail!
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions ...done.

If anyone could provide a solution for installing VB guest additions that would be great.

EDIT:

After running apt-get install build-essential dkms

The 2nd error changes to:

root@kali:~# ./VBoxLinuxAdditions.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.24 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 5.0.24 of VirtualBox Guest Additions...
Removing existing VirtualBox DKMS kernel modules ...done.
Removing existing VirtualBox non-DKMS kernel modules ...done.
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox DKMS kernel modules ...done.

Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module ...fail!
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions ...done.
  • Run apt-get dist-upgrade then try it again – GAD3R Dec 16 '16 at 19:46
  • @Christopher I did as you said and I get the same errors. I had run apt-get dist-upgrade previously and when running the command now, I only installed a few things. I rebooted then ran apt-get install linux-headers-$(uname -r), however it seems I'm at the newest version: 'linux-headers-4.8.0-kali2-amd64 is already the newest version (4.8.11-1kali1). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.' – dannychris37 Dec 16 '16 at 20:06
  • build-essential is already the newest version (12.2). build-essential set to manually installed. Suggested packages: python3-apport The following NEW packages will be installed: dkms linux-headers-amd64 – dannychris37 Dec 16 '16 at 20:45
  • @Christopher I get a different error for installing from CD. Check the edit. – dannychris37 Dec 16 '16 at 20:53
  • Afraid not, I ran the commands and nothing new was installed. I tried running ./VBoxLinuxAditions and get the same error. – dannychris37 Dec 17 '16 at 19:15
1

It worked after I installed v5.1. of VBox and did a fresh install of Kali. Upgrading from 5.0 with 5.1 with Kali installed messed up the VM for some reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.