3

I have the BCM423142 chip on my laptop, recently I've installed Arch Linux (Antergos) and downloaded the linux-headers and broadcom-wl-dkms packages from AUR.

WiFi works perfect but Bluetooth doesn't, it only appears as powered off in the gnome-panel.

screen capture

I have this output from the dmesg | grep Bluetooth command:

[   12.376925] toshiba_bluetooth: Toshiba ACPI Bluetooth device driver
[   15.655590] Bluetooth: Core ver 2.21
[   15.655611] Bluetooth: HCI device and connection manager initialized
[   15.655614] Bluetooth: HCI socket layer initialized
[   15.655616] Bluetooth: L2CAP socket layer initialized
[   15.655621] Bluetooth: SCO socket layer initialized
[   18.325428] Bluetooth: hci0 command 0x1001 tx timeout
[   18.373084] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   18.373088] Bluetooth: BNEP filters: protocol multicast
[   18.373094] Bluetooth: BNEP socket layer initialized
[   26.432140] Bluetooth: hci0: BCM: Reading local version info failed (-110)

I have this output from lsmod | grep blue

bluetooth             487424  12 btrtl,btintel,bnep,btbcm,btusb
toshiba_bluetooth      16384  0
rfkill                 20480  8 toshiba_bluetooth,bluetooth,toshiba_acpi,cfg80211
crc16                  16384  2 bluetooth,ext4

I have this output from the bluetooth command:

[bluetooth]# power on
No default controller available

I've already tried with this Installation and this Configuration via the CLI and none works.

  • Found this. but it is not trivial. <askubuntu.com/questions/632336/… – user192526 Dec 16 '16 at 14:12
  • @Bahamut : Any new drivers will add on new kernel release.You should read which kernel release he used it for broadcom bluetooth driver.Read the result of # lsmod command – supriady Dec 17 '16 at 8:58
  • Did you know how many lines of source code for kernel 4.x?Almost 5 million lines of souce code for kernel 4.x.Some very old drivers removed from new kernel release.Compiled kernel 4.x need almost 15 GB free space. – supriady Dec 17 '16 at 9:12
  • It's not a Problem from the driver, but firmware-problem. I found something in git maybe easier to handle. <github.com/winterheart/broadcom-bt-firmware – user192526 Dec 17 '16 at 9:30
0

I had the same problem. I use Arch Manjaro (Gnome). I solved it (more or less) using the "Fn" + "Wireless key". It works like a "on/off" for the bluetooth too.

Like your pictur, with Bluetooth window on screen: First I made "off", then "on" with the keyboard and right after the second action the Bluetooth works fine again.

I hope works for you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.