0

I have recently bough an usb wifi dongle with a MT7601U chipset to use with a Kali linux virtual machine, and everything is apparently set up correctly (usb enabled on virtual box, no apparent driver issues in the VM), but it doesn't see any wifi networks with a scan or with the network manager. I tried a couple things (upgrading and installing another driver) but none of that got it working. I can enable monitor mode without problems using ifconfig and airmon-ng, but airodump-ng also doesn't show any networks. The dongle works fine in windows with the manufacturer's driver, so it doesn't appear to be a problem with the dongle.

Has anyone solved this problem recently?

lsusb output:

Bus 001 Device 002: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

iwconfig:

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off

eth0      no wireless extensions.

iwlist scan

lo        Interface doesn't support scanning.

wlan0     No scan results

eth0      Interface doesn't support scanning.

rfkill list all

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  • Have you try to modify VBox settings for the dongle (add network card)...? – George Vasiliou Dec 16 '16 at 0:38
  • Do you mean add it as an adapter on the network options? I tried, but if I do it I won't have control over it inside the VM the way I need to. – Haykath Dec 16 '16 at 0:46
  • Is not clear what you try to do, but capabilities within VBox could be limited. I think the better option is to register all network adapters in Vbox, and then figure out /google how to use two network cards in VBox. Virtual net cards and "visual" settings could apply to Virtual machines limiting your capabilities or requiring a VBox workaround....like this: forums.virtualbox.org/viewtopic.php?f=3&t=36574 – George Vasiliou Dec 16 '16 at 0:53
  • In those examples the users want to add the network adapters as virtual adapters, which is not what I want to do. I am trying to use an USB wifi adapter directly from the VM, adding it as a usb device and fully controlling it instead of just receiving the connection from the host machine. – Haykath Dec 16 '16 at 2:15
0
  • First of all make sure that this wireless adapter is working and connecting to wireless networks on your host machine,

  • Then you can try before run airmon-ng, kill all the process wich can cause troubles with our promiscous scann, make sure to run this before start the monitor mode.

airmon-ng check kill

  • Look at dmesg log file, to check if there is any usefull message about the device turning on or off.

  • Also you can add a filter, wich will make the start of this device with the startup of the machine.

    Config/USB/add new filter, you only need to add Vendor and Device ID 148f:7601

Bus 001 Device 002: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter enter image description here

0

The MT7601U wifi driver is a part of linux kerenl 4.2and higher , you can check the mt7601u.bin under /lib/firmware :

ls /lib/firmware | grep 'mt7601u.bin'

If the firmware file is missing, first check if it's available pre-packaged by your Linux distribution. If not, you can download it here:

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/mt7601u.bin

Once you have the file, just place it into /lib/firmware/ directory.

To get the wifi working , load the module then bring up your wifi interface:

modprobe mac80211
insmod /lib/modules/$(uname -r)/kernel/drivers/net/wireless/mediatek/mt7601u/mt7601u.ko
ifconfig <interface> up
dhclient <interface>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.