1

I have problem with Caching DNS Server in Centos 7, when I try the dig command example

dig www.google.com

I get this output

; <<>> DiG 9.9.4-RedHat-9.9.4-29.el7 <<>> www.google.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 54269
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.google.fr.                 IN      A

;; Query time: 0 msec
;; SERVER: 192.168.0.100#53(192.168.0.100)
;; WHEN: Wed Dec 14 06:26:02 CET 2016
;; MSG SIZE  rcvd: 42

but when i change the dnssec-validation to no in the /etc/named.conf it work fine. any help

dig www.google.com

I get this output

dig google.com


; <<>> DiG 9.9.4-RedHat-9.9.4-29.el7 <<>> google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39355
;; flags: qr rd ra; QUERY: 1, ANSWER: 16, AUTHORITY: 13, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;google.com.                    IN      A

;; ANSWER SECTION:
google.com.             92      IN      A       41.201.129.30
google.com.             92      IN      A       41.201.129.54
google.com.             92      IN      A       41.201.129.29
google.com.             92      IN      A       41.201.129.25
google.com.             92      IN      A       41.201.129.50
google.com.             92      IN      A       41.201.129.59
google.com.             92      IN      A       41.201.129.24
google.com.             92      IN      A       41.201.129.40
google.com.             92      IN      A       41.201.129.34
google.com.             92      IN      A       41.201.129.44
google.com.             92      IN      A       41.201.129.20
google.com.             92      IN      A       41.201.129.45
google.com.             92      IN      A       41.201.129.49
google.com.             92      IN      A       41.201.129.39
google.com.             92      IN      A       41.201.129.35
google.com.             92      IN      A       41.201.129.55

;; AUTHORITY SECTION:
.                       169937  IN      NS      c.root-servers.net.
.                       169937  IN      NS      m.root-servers.net.
.                       169937  IN      NS      e.root-servers.net.
.                       169937  IN      NS      i.root-servers.net.
.                       169937  IN      NS      j.root-servers.net.
.                       169937  IN      NS      b.root-servers.net.
.                       169937  IN      NS      g.root-servers.net.
.                       169937  IN      NS      h.root-servers.net.
.                       169937  IN      NS      k.root-servers.net.
.                       169937  IN      NS      a.root-servers.net.
.                       169937  IN      NS      l.root-servers.net.
.                       169937  IN      NS      f.root-servers.net.
.                       169937  IN      NS      d.root-servers.net.

;; Query time: 85 msec
;; SERVER: 192.168.0.100#53(192.168.0.100)
;; WHEN: Wed Dec 14 04:44:52 CET 2016
;; MSG SIZE  rcvd: 506
0

I want to inform every one that the problem is solved, my lab was on Vmware workstation 12 but when i moved to Kvm everything worked fine, unbound and named both worked as expected and i didn't need to turn off dnssec-validation for named.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.