3

I have a Logitech Dual Action Controller that I am trying to use in a Centos virtual machine (using VirtualBox). The controller is in "D" mode (according to the switch on the back of the controller) and is passing through to the vm as Bus 001 Device 003: ID 046d:c216 Logitech, Inc. Dual Action Gamepad.

It shows up in /dev/input as event7. It should come up as js0 indicating that it is a joystick input.

I have tried:

  • Updating my kernel - no change
  • Installing joy-dev - no change
  • Running evtest to test the input of the controller - Evtest did not have any output no matter what button I pressed on the controller.
  • Using the controller in "X" mode (switch on the back of the controller) - Didn't create a new event or joystick in /dev/input.

Does anybody have any suggestions about how to correctly pass this controller through to my vm as a joystick?? I am out of ideas.

Thanks

Per the comment:

The output of dmesg when I grep for Logitech is:

[ 8308.864059] usb 2-1: Product: Logitech Dual Action

[ 8308.864061] usb 2-1: Manufacturer: Logitech

[ 8318.897422] input: Logitech Logitech Dual Action as /devices/pci0000:00/0000:00:06.0/usb2/2-1/2-1:1.0/input/input7

[ 8318.897859] hid-generic 0003:046D:C216.0001: input,hidraw0: USB HID v1.11 Joystick [Logitech Logitech Dual Action] on usb-0000:00:06.0-1/input0

Only one new event is created when I plug the controller in. While running Evtest for event7, nothing happens when I push buttons or move the joystick on the controller.

  • Please add output of dmesg when you plug it in. Apparently the kernel recognizes it as an HID device or something instead of a joystick, so I suspect it loads the wrong driver (though google says this device uses an HID interface). Do you see events when you move the stick? Are there possibly several /dev/input devices associated with the joystick? – dirkt Dec 15 '16 at 15:41
  • Have you tried installing VirtualBox Guest Additions in the Guest OS? – Chirag Bhatia - chirag64 Dec 20 '16 at 11:50
  • Take a look to udev rules. May be an existing rule mapping the joystick to the wrong device or you can add your own rule. – sgargel Feb 8 '17 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.