1

I'm trying to setup R1Soft backups and I run into the error

Could not find a suitable hcpdriver module for your system; Please run "r1soft-setup --get-module " on your Agent to install one.

So to resolve I've run the r1soft-setup --get-module command which tells me

Please install the kernel headers for your operating system.

To do this I run yum install kernel-devel

Which tells me

Package kernel-devel-2.6.32-642.11.1.el6.x86_64 already installed and latest version Nothing to do

I check my kernal version using uname -r and I see my kernal version is actually2.6.32-431.11.2.el6.x86_64

I then try install the headers for this kernel by running
yum install kernel-devel-$(uname -r) and yum install kernel-devel-$(uname -r) --disableexcludes=all

Each time I get back the message

No package kernel-devel-2.6.32-431.11.2.el6.x86_64 available. Error: Nothing to do

Now I'm at a bit of a loss as to what to do. It would appear that I'm running a different kernel than yum thinks I'm on, but also that the headers for the kernel I want just aren't available (according to yum)

Anyone know how I can get the correct headers so I can setup the hcpdriver module? I'm running CENTOS 6.8 on a virtual server from a hosting company

2 Answers 2

1

Kernel 2.6.32-431 is an old one and isn't in repositories already. So no related packages are there too. You should update your kernel (the latest one is 2.6.32-642.11.1, the same as you -devel package) and boot into it.

Anyway headers are within kernel-headers package.

0

I was able to manually install the correct devel package from pbone.net by using the command below

rpm -ivh --force ftp://mirror.switch.ch/pool/4/mirror/scientificlinux/6.5/x86_64/updates/security/kernel-devel-2.6.32-431.11.2.el6.x86_64.rpm

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .