1

I have a CentOS 6.7 system that is behind a firewall with no outbound. It is a vanilla, working rig.

I need to install: - jemalloc - redis

I have the rpm for jemalloc on the system locally, but it won't install complaining about requiring glibc

[root@localhost tmp]# rpm -ivh jemalloc-3.6.0-8.el7.centos.x86_64.rpm
error: Failed dependencies:
        libc.so.6(GLIBC_2.14)(64bit) is needed by jemalloc-3.6.0-8.el7.centos.x86_64
[root@localhost tmp]#

But that makes no sense to me, as glibc is in the local rpm repository, it appears to me:

[root@localhost tmp]# rpm -qa|grep glibc
glibc-2.12-1.166.el6_7.3.x86_64
glibc-headers-2.12-1.166.el6_7.3.x86_64
glibc-common-2.12-1.166.el6_7.3.x86_64
glibc-devel-2.12-1.166.el6_7.3.x86_64
[root@localhost tmp]# yum install glibc
Loaded plugins: changelog, fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
Error: Cannot retrieve metalink for repository: epel. Please verify its path and try again
[root@localhost tmp]

What am I missing?

  • jemalloc requires glibc 2.14 and you have version 2.12 installed. – n8te Dec 15 '16 at 5:18
  • @n8te Thanks, I see what you refer to. But for centos 6.7, there doesn't seem to be glibc 2.14 – samsmith Dec 15 '16 at 5:30
  • Have a look at this CentOS forum discussion. It's not a solution to your problem but worth reading as they strongly advise against trying to install glibc 2.14 on CentOS 6. – n8te Dec 15 '16 at 5:36
  • @n8te Thanks. I get it now. See answer I posted below. (I referred to a running centos 6.x system to see what versions of things were there) – samsmith Dec 15 '16 at 5:38
1

Answer: Use jemalloc 3.6.0-1 on Centos 6.x, do not use (or try to use) jemalloc 3.6.0-8, as that is for Centos 7....

  • +1 Glad to see you found an alternative solution. – n8te Dec 15 '16 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.