1

I hadn't run into one like this before. Had a failed yum update when trying to update a server this morning. Package that is failing is dracut-network. I went ahead and updated the rest of the packages by skipping these, but still trying to figure this one out.

Basically, dracut-network is having conflicts between 2 repositories. But the repositories are the Base and the @updates.

I went ahead and ran both yum distro-sync and yum clean all

When I run yum update, I still get a ton of errors relating to dracut-network conflicting packages.

When I run:

yum list | grep dracut-network

I get:

dracut-network.x86_64                    033-360.el7_2.1                @updates
dracut-network.x86_64                    033-463.el7                    base

The actual errors are all related to this conflict. There's about a dozen conflicts but all look like:

file /usr/lib/dracut/modules.d/95iscsi/parse-iscsiroot.sh from install of dracut-network-033-463.el7.x86_64 conflicts with file from package dracut-network-033-360.el7_2.1.x86_64

Unless I'm missing something obvious here, how do I correct conflicting versions when they're both vendor repo's?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.