I have a weird problem of connecting to a wireless network. I am connecting to a network named "C-202" with WPA-Personal. This network shows up in the scan results some time and won't show some time. I can't really figure out a pattern from this. Sometime the network won't show up. It may work after few restarts.

I was using Wicd initially and thought this was the problem with wicd. Uninstalled wicd and started using NetworkManager, but the problem persists. Then I tried the scan directly on terminal like

iwlist wlan0 scan

This shows a list of networks available, but not the one I want to connect. I can connect to that network from other computers, but not from this.

Interestingly, when I change the SSID from C-202 to C-202-New, it shows up in the list and I can connect. The connection works for few days and the problem starts again. Changing the SSID again will fix it. It looks to me like some cache is messing things up.

Wireless details

$ lspci -v | grep wireless
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    Subsystem: Intel Corporation PRO/Wireless 3945ABG Network Connection
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at d8000000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel driver in use: iwl3945

I have no clue on how to debug this issue. Can anyone help me to debug and fix this issue? Any help would be appreciated

  • More updates: Change the SSID to C-202-New. Rescan, it shows up. Now change it back to C-202 and rescan, it won't show up! Very weird. – Navaneeth K N Feb 29 '12 at 6:19
  • Are you in control of the access point? Have others using the access point had trouble? – Gilles Feb 29 '12 at 19:54

Something similar happened to me.

Because it had been bought abroad, the laptop I was using had wifi hardware that supported less channels than the ones supported by the AP (which was local). The AP was configured to automatically choose the channel depending on the other networks present in the area.

It chose a channel that wasn't supported by the laptop. I discovered this by using sudo iwlist eth1 channel that displayed less values (1 to 11 only) while the AP was displaying more possibilities (1 to 13, the web interface was showing that detail).

Happily I could force the AP to use a given channel that was supported by both sides through its configuration interface, everything worked just fine after that.

Downside: now if many people are using the channel I chose, the networking performance maybe be impacted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.