4

1.At the begining

mount | grep home 
/dev/sdb1 on /home type xfs (rw,relatime,attr2,inode64,noquota)

2.try to modify

mount -o remount,rw,relatime,attr2,inode64,prjquota  /dev/sbd1 /home

3.check it again

mount | grep home 
/dev/sdb1 on /home type xfs (rw,relatime,attr2,inode64,noquota)

It doesn' work.

cat /etc/fstab

#
# /etc/fstab
# Created by anaconda on Tue Aug  9 15:24:43 2016
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=8f1038a3-6c31-4ce1-a9ef-3d7325e10bef /                       ext4    defaults        1 1
UUID=c687eab8-3ddd-4756-b91e-ad562b522f7c /boot                   ext4    defaults        1 2
UUID=7ae72a46-1407-49e6-8669-95bb9e592794 /home                   xfs     rw,relatime,attr2,inode64,prjquota        0 0
UUID=3ccea12f-25d0-437b-9c4b-6ad6a9bd724c /tmp                    xfs     defaults        0 0
UUID=b8ab4016-49bd-4f48-9620-5bda76f4d8b1 /var/log                xfs     defaults        0 0
UUID=8b9a7ada-3f02-4ee5-8010-ad32a5d7461e swap                    swap    defaults        0 0

I can modify the /etc/fstab then restart machine make it work. But,is there any way I can change the quota configure without reboot?

1

According to RHEL documentation you can't:

XFS quotas are not a remountable option. The -o quota option must be specified on the initial mount for quotas to be in effect.

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Storage_Administration_Guide/ch03s09.html#idp21353040

Also I tried changing a user (test) quota using:

xfs_quota -x /home
xfs_quota> report -hu
User quota on /home (/dev/mapper/cl_backup--server-home)
                        Blocks              
User ID      Used   Soft   Hard Warn/Grace   
---------- --------------------------------- 
root            0      0      0  00 [------]
test        11,4G     9G    10G  00 [-none-]

xfs_quota> limit bsoft=30g bhard=32g test
xfs_quota> report -hu
User quota on /home (/dev/mapper/cl_backup--server-home)
                        Blocks              
User ID      Used   Soft   Hard Warn/Grace   
---------- --------------------------------- 
root            0      0      0  00 [------]
test        11,4G    30G    32G  00 [------]

xfs_quota> q

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.