4

i've installed fedora 25 today coming from mint !

every things goes great . but when i shake the laptop unintentionally the screen turn around and make a 90deg or 180deg rotate .

every time this happen i have to shake my lap in different position until i get the normal screen !

is there anyway to force fedora to don't detect shakes and laptop moves ?

or to force screen to be normal always ?

  • 1
    Most likely due to your hdd accelerometer, try disabling the plugin. – don_crissti Dec 13 '16 at 23:27
  • 1
    @don_crissti thank you ! the correct comment man – Mustapha Elbazi Dec 13 '16 at 23:35
  • 4
    There is also a cryptic button at the bottom of the top right applet (the one for network, Bluetooth, battery status, shutdown, etc) that can lock and unlock auto rotation. – Tim Jun 3 '17 at 18:24
  • 2
    @Tim 's comment fixes it to. – rhymsy Mar 9 '18 at 20:36
1

run this command as your STANDARD USER, replace cinnamon by the name of the desktop environment you are using (gnome...etc) :

gsettings set org.cinnamon.settings-daemon.peripherals.touchscreen orientation-lock  true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.