1

I am looking to install ftp (client) on my RHEL server. I can't access the internet directly, so I need to d/l the package.

I have downloaded ftp-0.17-17.2.x86_64 from redhat, and it is telling me:

libreadline.so.4()(64bit) is needed by ftp-0.17-17.2.x86_64

when I try and install readline-devel 4, it tells me a newer version is alreadyt installed; and readline 4 tells me it can't install because of conflicts with readline-devel.

find / -name libreadline* -print /lib64/libreadline.so.6.0 /lib64/libreadline.so.6 /usr/lib64/libreadline.so

Can anyone help me to know what the next step is?

3

1 Answer 1

2

Try to download a more recent version of ftp, for instance ftp-0.17-54.el6.x86_64.rpm

See link http://mirror.centos.org/centos/6/os/x86_64/Packages/ or http://mirror.centos.org/centos/6/os/x86_64/Packages/ftp-0.17-54.el6.x86_64.rpm directly.

From the ldd output you can see that it is linked to libreadline.so.6:

ldd /usr/bin/ftp
    linux-vdso.so.1 =>  (0x00007fffa67be000)
    libreadline.so.6 => /lib64/libreadline.so.6 (0x00007fe48362c000)
    libncurses.so.5 => /lib64/libncurses.so.5 (0x00007fe48340a000)
    libc.so.6 => /lib64/libc.so.6 (0x00007fe483075000)
    libtinfo.so.5 => /lib64/libtinfo.so.5 (0x00007fe482e54000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00007fe482c50000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fe48388b000)
2
  • fantastic, thank you :D out of interest, how did you know that a centos package would work for rhel? Dec 13, 2016 at 11:11
  • 1
    I just typed google ftp-0.17-54.el6.x86_64 in the address bar of my browser :-) And since CentOS is a fork of RedHat I know they share the same architecture. For further reading: en.wikipedia.org/wiki/CentOS
    – Lambert
    Dec 13, 2016 at 11:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .