12

I'm running Arch Linux with Mate Desktop version 1.16.0 on Linux kernel 4.8.13. I have a weird problem. My screen turns black after around 5 or 10 minutes and I can not find out why. Here is my mate configuration:

screenshot

As you can see, the power-management is completely disabled and set to never go to sleep or turn off the display. And the screensaver is set to 2 hours minimum and also disabled.

I have no idea what else I could check. I went through the whole mate control panel to find any hidden settings. Does anyone have any idea why my screen turns black after approximately 10 minutes idle time?

10

XServer has its own settings for power management and screen saving functions. From the man page:

Option "BlankTime" "time"

sets the inactivity timeout for the blank phase of the screensaver. time is in minutes. This is equivalent to the Xorg server’s −s flag, and the value can be changed at run−time with xset(1). Default: 10 minutes.

Try these commands to completely disable the power management setting for X. Open a terminal and run the following:

xset -dpms # Disables Energy Star features
xset s off # Disables screen saver

If this works for you, to make these settings permanent in one of the files for .xorg.conf configuration files. Use man xorg.conf and pick one of the config file location files.

Example xorg.conf settings for these values:

Section "Monitor"
Identifier  "Monitor1"
    Option "DPMS" "false"

Section "ServerFlags"
    Option "BlankTime" "0" # Not sure if a value of 0 here will disable this

Alternately you can use a .xinitrc file if you are using xinit to start your X session and just insert the xset commands from above (my preference).

Edit: From comments below the xorg.conf route seems to not work. I haven't had much luck making sense of the options needed to disable DPMS from this route, so YMMV. I did enjoy this snippet from the man page however:

VIDEOADAPTOR SECTION
   Nobody wants to say how this works.  Maybe nobody knows ...
5
  • 2
    Accurate answer and exactly what I was looking for. Screen was on all night :)
    – Afr
    Dec 13 '16 at 10:10
  • 1
    I tried the xorg.conf method. I put a file with the contents from the code block here at the path /etc/X11/xorg.conf.d/keep_screen_on.conf and it made X no longer start at system boot. I'll try the .xinitrc method now. Aug 12 at 17:52
  • Recently I've even had it in a script that runs on boot (after KDE starts) and the screen still turns off after a while. There's a button "Inhibit automatic sleep and screen locking" in the menu of my battery tray icon, but I would have to click that manually after every single reboot and I don't even know yet if it helps. Sep 9 at 9:22
  • I can confirm, like @FabianRöling, that the system does not boot anymore with the xorg.conf method. Removing the config from a live ISO resolves the issue.
    – Nakrule
    Nov 16 at 17:58
  • Technically the system boots, just not the X system. You can press e.g. Ctrl+Alt+F2 to switch to a separate, terminal-based session and execute commands from there. Nov 17 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.