6

I was trying to update the drivers of a system with a couple of Nvidia GTX 980 cards but somehow I messed up and now I encounter this error when I run the installer with Nvidia:

ERROR: An NVIDIA kernel module 'nvidia-uvm' appears to already be loaded in your kernel.  This may be because it is in use (for example, by the X server), but may also happen if your kernel was configured     
     without support for module unloading.  Please be sure you have exited X before attempting to upgrade your driver.  If you have exited X, know that your kernel supports module unloading, and still       
     receive this message, then an error may have occured that has corrupted the NVIDIA kernel module's usage count; the simplest remedy is to reboot your computer.

lsmod | grep -i nvidia gives:

 nvidia_uvm             77824  0 
 nvidia               8540160  77 nvidia_uvm
 drm                   344064  4 nvidia

So the suggestion that an error may have occured that corrupted the kernel module usage count makes sense, however, the remedy does not help and rebooting does not do a thing. I have tried blacklisting both modules in different ways and no matter what I do they are always back. Doing rmmod or modprobe -r does not help either. In fact with the later I get:

modprobe: FATAL: Module nvidia-uvm not found.

I have tried everything I found on the net, nothing changed that 77 there.

Any ideas? Thanks!

0

2 Answers 2

5

I had the same problem. It turned out that a program was running that prevented nvidia-uvm from unloading.

In order to find out what that program was, I did

#lsof | grep nvidia.uvm

(if needed with sudo) and that gave me the hint as to what was using the module. I got that from this answer: https://stackoverflow.com/questions/448999/is-there-a-way-to-figure-out-what-is-using-a-linux-kernel-module

Then I uninstalled that program because I didn't actually need it, and everything was working again. If you do need the program, you can probably just terminate it or kill it for the time being, and then start it again when you're done.

1

Try adding the following to your boot parameters in grub:

nouveau.modset=0

To do this, interrupt the grub loader by pressing e when the grub loader screen is showing, and add the above command to the linux command, either at the end or before the --- if those dashes are present. When you are done editing F10 will boot.

This will prevent the open-source nouveau NVIDIA driver from being loaded while you troubleshoot the issues.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .