6

Under Debian Jessie i had for the first time backports in my package-source.

I had some collision in apt, because some packages i had installt from http://www.deb-multimedia.org/ have higher versions in backports.

First pin-priority for multimedia was 100. I try to set the priority for backports to -1, but it didn't work.

LANG=C cat /etc/apt/preferences
Package: *
Pin: origin deb http://http.us.debian.org/debian jessie-backports main
release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
Pin-Priority: -1

Package: *
Pin: origin deb http://http.us.debian.org/debian jessie-backports main
release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
Pin-Priority: -1

Package: *
Pin: origin deb http://http.us.debian.org/debian jessie-backports contrib
release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
Pin-Priority: -1

Package: *
Pin: origin www.deb-multimedia.org
Pin-Priority: 300 
`

What is wrong with my /etc/apt/preferences

     LANG=C apt-cache policy | grep backports | egrep -i -v translat
 100 http://http.us.debian.org/debian/ jessie-backports/non-free i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
 100 http://http.us.debian.org/debian/ jessie-backports/contrib i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
 100 http://http.us.debian.org/debian/ jessie-backports/main i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
 100 http://http.us.debian.org/debian/ jessie-backports/non-free amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
 100 http://http.us.debian.org/debian/ jessie-backports/contrib amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
 100 http://http.us.debian.org/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main

The folder

ls -al /etc/apt/preferences.d/
insgesamt 8
drwxr-xr-x 2 root root 4096 Jan 25  2011 .
drwxr-xr-x 6 root root 4096 Dez 11 11:53 ..

is empty.

  • 2
    I was searching a little bit more. The standart prioritiy are selected in head -n11 /var/lib/apt/lists/http.us.debian.org_debian_dists_jessie-backports_InRelease -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA256 Origin: Debian Backports Label: Debian Backports Suite: jessie-backports Codename: jessie-backports Date: Tue, 13 Dec 2016 20:38:15 UTC Valid-Until: Tue, 20 Dec 2016 20:38:15 UTC NotAutomatic: yes ButAutomaticUpgrades: yes Codewort NotAutomatic:yes. – user192526 Dec 14 '16 at 9:19
5

You only need one entry with the appropriate archive name:

Package: *
Pin: release a=jessie-backports
Pin-Priority: -1

Note that backports are pinned to 100 by default so they are not installation candidates unless you specify -t jessie-backports. I don't know how that plays with packages from other sources though, especially if they have higher versions than the stable packages...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy