2

I have Vim version 8.0.122 on FreeBSD 9.3 (installed with pkg). I have default global vimrc. I want to disable mouse support completely on my account, so I put

    set mouse=

in my local .vimrc. It works, mouse is disabled, but also autoindent is gone, i.e. I press enter in a .php or .c file and I'm back at the begining of the line instead of current indent position.

I want to have both, mouse disabled, autoindent working as it used to. What should I do?

2
  • 1
    Please add to the post how you disabled it. Dec 12 '16 at 13:08
  • They are not linked in any way. To debug, make a simple .vimrc file containing just set nocompatible, set all&, set ai bs=2 mouse= and check that everything works correctly. Then try to isolate the problem.
    – AlexP
    Dec 12 '16 at 13:17
1

I faced a similar problem. This is what helped me solve it. On my computer the vim settings which made many things pretty are stored in /usr/shar/vim/vim*/defaults.vim, but this file was read only if there is no ~/.vimrc. So if you can either copy this entire file to you ~/.vimrc, or if you are an admin and want to make a change for all users, modify the file itself. Just comment out the line which says set mouse=a.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.