I am running a kde on CentOS 7. KDE community page doesn't have any rpm for this and I don't if downloading from other websites is safe or not.

I tried installing using the tar.bz2 but the process is very cumbersome and I am facing issues with installing dependencies. Below is the result from yum

[root@localhost CMakeFiles]# yum install amarok                                                                                                                                                      
Loaded plugins: fastestmirror, langpacks                                                                                                                                                             
Loading mirror speeds from cached hostfile                                                                                                                                                           
 * base: mirror.redsox.cc                                                                                                                                                                            
 * extras: centos.aol.com                                                                                                                                                                            
 * updates: reflector.westga.edu                                                                                                                                                                     
No package amarok available.                                                                                                                                                                         
Error: Nothing to do            

You can install Amarok from EPEL repository. Like this:

# first get EPEL repository
wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
# install EPEL
yum install epel*rpm
# install Amarok
yum install amarok
  • thanks this worked. how were you able to find this out? because I searched a lot and none of the forums seemed to point to this repository. – Shashank Vyas Dec 14 '16 at 4:04
  • You're welcome :) It was just from quite long experience with linux, and I have also used Amarok myself. – StefanR Dec 14 '16 at 8:37

You can try to download it manually from rpm.pbone.net.You also can download all dependencies from there.When you didnt want to compile it from tarball.Or you can download puias cmputional repos from there.I am not sure for KDE users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.