2

Today I installed Google Chrome 55 (i.e. the latest stable version) on 64-bit SL7.0 using a 64-bit RPM. The problem is that google chrome starts fine (except for an SELinux-related issue which I fixed), but it closes without warning after about a minute. No indication of a crash is shown except for "Google Chrome crashed. Would you like to restore your tabs?" the next time I start it (only to happen again, after a minute), and the following output from the terminal when I start chrome there:

$ google-chrome

...

Failed to get crash dump id.
Report Id: 
Segmentation fault (core dumped)
$

Reinstalling chrome did not fix the problem. Nether did deleting my profile folder so chrome can use the defaults.

This is the output when I ran systemctl status abrtd -l:

abrtd.service - ABRT Automated Bug Reporting Tool
   Loaded: loaded (/usr/lib/systemd/system/abrtd.service; enabled)
   Active: active (running) since Sat 2016-12-10 08:22:53 EAT; 7h ago
 Main PID: 698 (abrtd)
   CGroup: /system.slice/abrtd.service
           └─698 /usr/sbin/abrtd -d -s

Dec 10 15:26:10 localhost.localdomain abrt-server[14419]: Package 'google-chrome-stable' isn't signed with proper key
Dec 10 15:26:10 localhost.localdomain abrt-server[14419]: 'post-create' on '/var/tmp/abrt/ccpp-2016-12-10-15:26:04-13832' exited with 1
Dec 10 15:26:10 localhost.localdomain abrt-server[14419]: Deleting problem directory '/var/tmp/abrt/ccpp-2016-12-10-15:26:04-13832'
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

In particular, Package 'google-chrome-stable' isn't signed with proper key: Is this a problem? I downloaded it from google's official site. What should I do now?

  • Assuming SL7 uses systemd like RHEL7, use coredumpctl to look at the dump, see this answer. – meuh Dec 10 '16 at 12:16
  • @meuh coredumptcl isn't on my system, and systemd-coredumptcl list says: No coredumps found. Tried as my home user & root, even started google-chrome again so it can register a core dump, crashed and still no core dumps found. – Cool Charac Dec 10 '16 at 12:30
  • Perhaps you have a zero core limit: ulimit -c. Or you may be running abrtd which manages core dumps, check with systemctl status abrtd. – meuh Dec 10 '16 at 12:38
  • Does abrt-cli list show any dumps still around? It looks like abrtd took the core dump then removed it? – meuh Dec 10 '16 at 12:51
  • abrt-cli list shows me a few dumps unrelated to google-chrome. In the past it would alert me if some program went wrong, but it's not reporting anything for chrome this time. It also said automatic bug reporting was disabled so I ran abrt-auto-reporting enabled as root. Then I made chrome crash again - still no report. – Cool Charac Dec 10 '16 at 13:02
1

I am unable to debug the problem with gdb (bt only gives me hexadecimal numbers, not function names).

Since, for the severity of this bug, everyone using the current version should have been affected (Quite a number of people have this bug too, according to the bug tracker). Seeing that a few other people have this problem (on chrome AND chromium), I assume this is a Chromium bug and/or something on the computer is causing the problem.

I'm going to file the bug on the Chromium bug tracker, I bet they're going to fix it. :]

Update: This is the bug report I posted.

Update #2: It seems like this is a GNOME-specific issue, and it works fine on KDE Plasma, so that's what I'll be using from now on.

  • 2
    You can try to run chrome from command line with all plugins disabled to see if makes any difference: google-chrome-stable --disable-gpu --disable-extensions --disable-d3d11 --disable-local-storage --disable-notifications --disable-offne-pages --disable-plugin-power-saver --disable-plugins-discovery --disable-sync --disable-translate --disable-webgl --no-experiments --no-sandbox. – George Vasiliou Jan 26 '17 at 10:59
0

My suggestion : download vivaldi from vivaldi.com that worked smoothly.Vivaldi was clone of google-chrome.

  • Vivaldi (like Opera, Comodo Dragon, etc.) is also built on top of Chromium, which are all technically clones. I tried opera and vivaldi on windows, but I want chrome to sync with my google accounts. I'd rather wait till they release a patch. – Cool Charac Dec 12 '16 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.