Have two Android phones Motorola and HTC both not working on Cinnamon 18. They were both working on Cinnamon 17.2.

I have installed MTP tools. The commands mtp-detect and lsusb both return Vids and Pids with no apparent errors.

Plugging in the phones I select File Transfers but nothing happens ie no connection sound and no auto nemo popup, opening nemo manually shows no mobile phone.

I also have USB Debugging on under Developer Options.

Any help I'd be grateful Thank you.

  • Thank you for your responses GAD3R and Gilles, Followed your instructions without problems except for the last instructions which I think are OK anyway. rudi@rudi-linux ~ $ sudo mkdir /media/android [sudo] password for rudi: mkdir: cannot create directory ‘/media/android’: File exists rudi@rudi-linux ~ $ rudi@rudi-linux ~ $ sudo chmod a+rwx /media/android rudi@rudi-linux ~ $ rudi@rudi-linux ~ $ sudo adduser $USER fuse The user rudi' is already a member of fuse'. rudi@rudi-linux ~ $ So if the last steps are OK then still no luck. – rudi Dec 11 '16 at 1:07
  • Sheesh, sorry about the formatting, new to this forum obviously. – rudi Dec 11 '16 at 1:11
  • Two developments. – rudi Dec 11 '16 at 4:49
  • Two developments. On an identical laptop with a clean install of mint cinnamon 17.3 the phone is recognized and all is well. On the computer running mint cinnamon 18 (the one that doesn't work) if I select CD Insaller instead of File Transfers the phone appears in Nemo and Disks in the start menu. – rudi Dec 11 '16 at 5:15
  • Further research. I have VirtualBox installed with Windows 10 guest and Linux Cinnamon 18 host. The phones HTC and Motorola work perfectly in Windows 10. At least I have somewhere to back things up. – rudi Dec 11 '16 at 8:42

Solved The problem was "Gvfs-Backends" package was not installed. Installed it via Synaptic Package Manager. How it became uninstalled is a mystery. I found this by comparing Gvfs packages on a working laptop to the not working laptop in the Synaptic Package Manager, for those who may encounter this problem. So everything now behaves as it should. Thanks all, Rudi


Create an udev rule:

editor /etc/udev/rules.d/51-android.rules

with the following contents:

SUBSYSTEM=="usb", ATTR{idVendor}=="put_the_idVendor_here", ATTR{idProduct}=="put_the_idProduct_here", MODE="0666"

Then plug in your Android device, the command mtp-detect will display the idVendor and the idProduct. Or, if the device is already plugged in, tell udev to re-create the device with udevadm trigger -a idVendor="put_the_idVendor_here".

Edit the fuse.conf :

editor /etc/fuse.conf

uncomment user_allow_other to be:

# Allow non-root users to specify the allow_other or allow_root mount options.

Create a mount point :

sudo mkdir /media/android
sudo chmod a+rwx /media/android
sudo adduser $USER fuse

Enable the MTP from your device settings.

  • 1
    Why would you be restarting udev? – heemayl Dec 10 '16 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.