0

evolution 3.22.2

Since upgrading to Fedora25, evolution does not connect anymore to the exchange server outlook.office365.com anymore. The connection to the latter was/is configured through gnome's "Online Accounts" settings. This seems to be independent of wayland.

Simply speaking: the server does not show within the evolution interface.

I tested it also on a blank new user account on the fedora machine and tried to get the connection; did not succeed.

Should I consider this a bug? but of what? or how would you work towards making this work again? Cheers!


Edit in response to comments:

installing evolution-ews helped; but required restart of complete system; restarting the gnome session did not suffice.

  • You can try to manually downgrade Evolution, if it will solve the problem. The other problem might be outdated security algorithms used by office365.com. – Jakuje Dec 9 '16 at 16:45
  • 1
    Some code may have been spun off into a separate package. Try installing evolution-ews or evolution-mapi if you dont have them. – meuh Dec 9 '16 at 19:05
  • installing evolution-ews helped; but required restart of complete system; restarting the gnome session did not suffice. If you post that as an answer, I shall accept it – ingli Dec 9 '16 at 21:55
2

Sometimes packages get split into 2 or more packages as they grow too large or drag in too many dependencies. This may be what happened to evolution. I checked with

$ sudo dnf search evolution | egrep -i exchange
evolution-ews.x86_64 : Evolution extension for Exchange Web Services
evolution-mapi.i686 : Evolution extension for MS Exchange 2007 servers
evolution-mapi.x86_64 : Evolution extension for MS Exchange 2007 servers

that there were some extra packages available, and with

$ sudo dnf install evolution

we can see that they are not installed by default. Searching the web finally found a gnome page Connecting to Exchange Servers:

Choosing the right connector. Depending on the version of the Microsoft Exchange server that you would like to connect to it is required to make sure that an additional package is installed that provides this functionality.

For Microsoft Exchange 2007, 2010 and newer it is recommended to use the package evolution-ews.

I don't know why you had to reboot instead of simply restarting gnome. The extra package consists mainly of shared libraries. Perhaps evolution kept a cache of what libraries were installed and didn't notice the new ones until a reboot.

0

I would advise deleting the old account and setting it up as a new account from scratch.

Here's a guide for setting up Exchange accounts in Evolution: https://cms.ysu.edu/sites/default/files/documents/Office_365_Mail_Client_Configuration_Guide_Evolution.pdf

Recently Microsoft upgraded Outlook.com and advised folks to delete/re-add their accounts into their email clients. This upgrade may be what's holding you back. Sounds like Outlook.com needs to re-verify everything because of new security settings on Microsoft's end.

  • thanks, I tried that multiple times but to no effect. – ingli Dec 10 '16 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.