I have noticed that FUSE is poorly documented for CentOS and I would like to run an AppImage on CentOS 7. I have installed all FUSE-related packages via running:

sudo yum install -y fuse* afuse

this command ran without any apparent error messages. I have ran:

sudo modprobe fuse

yet still when I try to execute an AppImage I get the error:

Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage 
if you run it with the --appimage-extract option. 
See https://github.com/probonopd/AppImageKit/wiki/FUSE 
for more information
open dir error: No such file or directory

must admit the Wiki article I was directed to was rather useless to a CentOS user as it was more directed to users of Debian-based and SUSE-based distributions. I have also tried using sudo gpasswd -a fusion809 fuse (where fusion809 is my username) and it failed as fuse was not a group in /etc/groups.

  • Interesting! I have the same problem (see this question of mine). I though that the AppImage uses its own FUSE, so that nothing needs to be installed, but maybe I am wrong. In any acse, it does not work for me either. – halloleo Apr 24 '18 at 4:23

Official wiki: https://github.com/AppImage/AppImageKit/wiki/FUSE

yum --enablerepo=epel -y install fuse-sshfs # install from EPEL
usermod -a -G fuse "$user" 

Have you tried adding yourself to the fuse group?

usermod -aG fuse $USER
  • Sure have. Sorry should have mentioned, I used gpasswd but still, I'll add to my question. – BH2017 Dec 9 '16 at 17:07

You probably did not actually install all the fuse packages when you did yum install fuse*... as there are packages with names that do not begin with fuse.... In particular you probably need package gvfs-fuse.

  • I installed gvfs-fuse and still getting the same error message whenever I try running my AppImage. This is despite rebooting after installing gvfs-fuse. – BH2017 Dec 10 '16 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.