I have an OpenSUSE VM running in VMware given to me as part of a project. It acts as a database container and the DB is hydrated by an outside script.

I started getting space warnings during the build process and build seems to be stalling so I tried to increase disk size from 20GB to 35GB.

Inside of My Computer in OpenSUSE, it's telling me there is only 18.6GiB total space.

I've restarted multiple times with no luck. Also, the new 35GB is pre-allocated.

I don't know if this will fix the build issue, but can someone help get the vm to recognize the full space allocated? Should at least help...

Extra info:

  • OS: Linux x86_64
  • System: openSUSE 11.4 (x86_64)
  • KDE: 4.6.00 (4.6.0) "release 6"

1 Answer 1


Obviously the additional disk space is not visible by the vm because it is not allocated to a partition.

The solution is to resize the partition of the vm.

A first step involves getting the unallocated space into the last partion, which can be done using parted. See https://www.gnu.org/software/parted/manual/html_node/parted_31.html

The second step is to grow the filesystem of the partition to fill the new space. The way to do it depends on the format of the partition. Eg in case of ext4 you can find instructions at https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Storage_Administration_Guide/ext4grow.html

  • Thanks. Well I ran resize2fs /dev/sda2 and got... resize2fs 1.41.14 (22-Dec-2010) The filesystem is already 4955648 blocks long. Nothing to do!
    – Liandri
    Dec 9, 2016 at 0:50
  • What is output of fdisk -l /dev/sda ?
    – jsalatas
    Dec 9, 2016 at 0:52
  • just upload it in pastebin or something like that.
    – jsalatas
    Dec 9, 2016 at 1:00
  • Screenshot, haha prnt.sc/dh4hec
    – Liandri
    Dec 9, 2016 at 1:04
  • OK. My bad. I edited my answer. Hopefully it should be complete now :)
    – jsalatas
    Dec 9, 2016 at 1:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .