I am trying to configure NUT for my Mecer UPS and it is asking me for the port that the UPS is connected to, in the NUT ups.conf example it shows

port = /dev/ttyS1

How can I determine the port that the UPS USB is connected to?

The Linux is CentOS 6 and it is a Mecer USB UPS.

I tried to plug it in and run dmesg put I can't make any sense of the output

usb 1-6: new low speed USB device number 103 using xhci_hcd
usb 1-6: New USB device found, idVendor=0665, idProduct=5161
usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-6: Product: USB to Serial
usb 1-6: Manufacturer: INNO TECH
usb 1-6: configuration #1 chosen from 1 choice
generic-usb 0003:0665:5161.0067: hiddev96,hidraw0: USB HID v1.00 Device [INNO TECH USB to Serial] on usb-0000:00:14.0-6/input0
  • What do you get if you ls /dev/tty*? In my experience USB tty's often get named something like /dev/ttyUSB01.
    – David King
    Commented Dec 8, 2016 at 14:02
  • @DavidKing I seem to only get tty0 to tty63 and ttyS0 to ttyS3 Commented Dec 9, 2016 at 6:28

1 Answer 1


The CentOS rpm probably comes with utility nut-scanner which will do the hard work for you. Run it to check for any suitable usb devices:

$ nut-scanner -U

and it will ouput a suitable stanza if it finds the device. Since it seems your device has been recognised as HID (human interface device) you will probably just need a minimal ups.conf entry giving the driver:

 driver = usbhid-ups
 port = auto
 desc = myMecer
  • Thanks for the response, I tried the entry you suggested but when I ran upsdrvctl start I got an error saying No mathcing HID UPS found, Driver failed to start (exit status=1) Commented Dec 9, 2016 at 6:31
  • Run nut-scanner.
    – meuh
    Commented Dec 9, 2016 at 6:51
  • 1
    It seems that if I changed the driver to blazer_usb and installed usbutils then it seems to find the UPS. It seems the problem was related to a combination of the wrong driver and missing the usbutils. Your answer was the most helpful to get me on the right track so I will mark this as the answer Commented Dec 9, 2016 at 7:28
  • Thanks. I have an Eaton UPS and lots of packages already installed so I didnt see any problems when doing the scan and config. Your experience and solution will no doubt help others with the same problem.
    – meuh
    Commented Dec 9, 2016 at 8:17
  • All the other UPS I have set up have been Eatons, I love them they just cooperate with Linux so nicely Commented Dec 9, 2016 at 9:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .