1

Today I updated the linux kernel to 4.8.12-2 using pacman -Suy. Next time I tried to turn on my computer, I got the following error:

Starting vmlinuz-linux
Using load options 'ro root=UUID=1d7....... initrd=\initramfs-linux.img'
EFI stub: ERROR: Failed to read file
Trying to load files to higher address
EFI stub: ERROR: Failed to read file

Using an arch live usb, I backed up /boot/vmlinuz-linux and installed version 4.8.11-1. Now, when I try to boot, only the lts version shows up in the rEFInd submenu (both lts and non-lts used to show up). When I try to edit /boot/EFI/refind/refind.conf, I get an input/output error.

Please help me. I am totally lost at this point. Just hoping my laptop isn't lost.

  • Chroot in, make sure / and /boot are mounted, and rerun the upgrade. In all likelihood, /boot was not mounted during your last upgrade. – jasonwryan Dec 8 '16 at 5:33
  • @jasonwryan /boot was definitly mounted. If it were not, wouldn't the upgrade have had no effect anyway? – Marcel Dec 8 '16 at 5:48
  • No, it would have just installed the kernel to the wrong place, which would lead to the situation you are describing. – jasonwryan Dec 8 '16 at 5:53
  • I tried that and it didn't work. My exact commands were mount /dev/sda1 /mnt; mount /dev/sda2 /mnt/boot; arch-chroot /mnt; pacman -Suy – Marcel Dec 8 '16 at 5:59
1

Somehow, my esp got corrupted. After backing everything up and running S.M.A.R.T. tests to make sure it wasn't a hardware issue, I reformatted the esp and reinstalled rEFInd:

 mkfs.fat -F32 /dev/sda2
 refind-install --usedefault /dev/sda2
 cd /var/cache/pacman/pkg
 pacman -U linux-4.8.12-2-x86_64.pkg.tar.xz
 mkinitcpio -p linux
| improve this answer | |
0

Just found out that EFI stub: ERROR: failed to read file. (at least in my case) actually refers specifically to initrd (which had been nuked by an unplanned shutdown during updates).

someone changed the message to 'generalize' the code at some point.

| improve this answer | |
0

I faced the same problem. When system update was running, my laptop suddenly turned off (I have no idea why), and when I tried to boot it I saw the same message. I fixed it this way: I booted from rescue flash drive. Then:

  1. wifi-menu - enable wifi network.
  2. mount /dev/sda2 /mnt
  3. arch-chroot /mnt
  4. mount -o rw /dev/sda1 /boot
  5. cd /var/cache/pacman/pkg
  6. pacman -U linux-4.8.12-2-x86_64.pkg.tar.xz

Package was reinstalled. It notified me that there were problems with some file and they were fixed. After that I closed session and unmounted all drives and rebooted. System boots ok now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.