2

I am facing this issue since ~2 years, so many different kernel versions were used, using openSuse and Ubuntu distributions, it makes no difference. The wireless cards are USB TP-Link TL-WN721N and TL-WN822N.

The internet connection is good all the time until I load the wireless interface with somewhat more extensive download, sometimes a file of 30MB is enough, no rule. Then the connection is lost until I disconnect the USB card and put it back. The dmesg says nothing upon the issue occurrence. The same for /var/log/kern.log and /var/log/syslog. The issue is reproducible on Linux on wlan, not reproducible on wired connection. It happens when I download via web browser from the Internet but also from local NAS via NFS (using mc). It does not matter whether the USB card is attached to mainboard USB sockets or LCD display USB hub. It happens significantly more often when the download is using all card's badwidth than when I download at ~1MB/s rate. It is not reproducible on Windows no matter how large files I download. No logs I know of say anything.

What logs can I check?

2

I had similar Problems with the module athk9.

I solved it, with deactivating of the powermanagement.

touch /etc/modprobe.d/ath9k.conf

then

echo "options ath9k ps_enable=1" | tee -a /etc/modprobe.d/ath9k.conf

More parameters are shown by the command : modinfo ath9k -F parm

With systemd you can use journalctl -b | egrep -i 'wpa|network|firm' to search for some relevant entries.

  • I tried this with no luck, both 'ps_enable=1' and 'ps_enable=0'. Additionally to the issue description provided above, when the issue occurs it is not enough to just restart network-manager, I need to detach USB card and attach it again. – tml Dec 9 '16 at 20:59
  • check list. encryption in Router and Network-manager WPA2. – user192526 Dec 10 '16 at 10:39
  • Check list. encryption in Router and Network-manager WPA2. To deactivate powermanagement the value mußt be 1. Another Problem can be the hardware encryption. It can be disabled with options ath9k nohwcrypt=1 journalctl -b | grep -i dhc will show if a Problem with dhcp exist. wrong keysttroke again. – user192526 Dec 10 '16 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.