2

After Xorg starts, keyboard doesn't work. It's even impossible to change tty. I've extracted logs and it says

[    14.990] (EE) Failed to load module "libinput" (loader failed, 7)

and

[    14.989] (EE) Failed to load /usr/lib/xorg/modules/input/libinput_drv.so: /usr/lib/x86_64-linux-gnu/libinput.so.10: version `LIBINPUT_1.5' not found (required by /usr/lib/xorg/modules/input/libinput_drv.so)

Full log: http://pastebin.com/hze08rbG

How can I solve it using other linux or disabling Xorg someway?

  • Is it only the keyboard or any input device? – Thushi Dec 7 '16 at 19:33
  • Also do you have two video cards? If possible please do paste the contents of xorg.conf. – Thushi Dec 7 '16 at 19:33
  • By looking at the logs. You have disabled the integrated video card which is intel. Also please let me know which NVIDIA driver are you using? – Thushi Dec 7 '16 at 19:36
  • FWIW, If you are not at all able to use keyboard. Then go into recover mode and get the root access and run systemctl set-default multi-user.target and reboot the system. At least that should make you to use the keyboard and give the information which I asked in my previous comments. – Thushi Dec 7 '16 at 19:39
  • I have two video cards (intel HD 530 and Nvidia a 960m, probably with newest default drivers, I don't know how to check it with different linux) xorg.conf: pastebin.com/8kH5Zmsm One more thing: before it happened I tried to install xf86-input-libinput in order to fix touchpad (some functions were inactive). It hasn't solved the problem, I had to use this github.com/vlasenko/hid-asus-dkms – tyrtyrtyrtyr Dec 7 '16 at 19:51
0

Ok, So looking at the logs and the comments.Here is my first set of analysis,

You have two video cards,

  • Intel which is integrated video card
  • Nvidia 960M

Which is called as Optimus setup.

By default now you are switched to Nvidia driver which is somehow causing the problem.

To get rid off this problem first you should try not to boot till graphical.target.

Try not to boot till graphical.target

  • Go to recovery mode and get the root shell.
  • Remount the rootfs using mount -o remount,rw /
  • Enable multi-user.target which is not really required but kind of double check using systemctl enable multi-user.target --force
  • Set default target to multi user using systemctl set-default multi-user.target
  • Reboot the system.

So now you should get a login prompt and enter your login username and password.

Uninstall the Nvidia drivers

This is bit tricky, You need to identify the drivers which are installed. Some of the distribution provides drivers along with their release which is proprietary and tested. There are other third party drivers like Noveau. So,

  • Search for the available drivers which are in your repo using apt-cache search nvidia. I hope which should list some of the packages like nvidia-364 nvidia-304 nvidia-noveau.
  • If you are not sure about the one which you have installed then try uninstalling all. For example, If you are using nvidia-304 then sudo apt-get purge nvidia-304
  • Again kind of fail safe measurement, try reinstalling Xorg using sudo apt-get install --reinstall xorg.
  • Once you are done with all these steps, flush your buffer using sync and reboot. Again you will get the login prompt and just login and proceed for the next steps.

Switch back to graphical.target

In this phase try to switch back to graphical.target to test your luck ;)

  • Boot into recover mode.
  • Remount the rootfs mount -o remount,rw /
  • Switch to graphical.target using sudo systemctl set-default graphical.target
  • Flush the buffer using sync
  • Reboot the system.
  • That should bring your UI up along with all the input devices working.

Cheers!

  • It turned out that I installed some unnecessary libraries (xf86-input-libinput) – tyrtyrtyrtyr Dec 8 '16 at 15:09
  • Now it works, but after I login xorg restarts. Log: pastebin.com/4wBdzcG6 – tyrtyrtyrtyr Dec 8 '16 at 15:09
  • Can you please elaborate a little? Nothing has changed yet. Still Nvidia drivers are being used, not the intel one. – Thushi Dec 9 '16 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.