0

I have Debian testing. My version of gcc is :

gcc (Debian 6.2.1-5) 6.2.1 20161124

I would like to install the version 4.7 of gcc but any attempts fail. I added

deb http //ftp.fr.debian.org/debian/ wheezy main contrib non-free

to have the packet available via apt-get

or I troed to download the .deb here

https://packages.debian.org/wheezy/amd64/gcc-4.7-base/download

but it fails with the error:

dpkg: dependency problems prevent configuration of gcc-4.7-base:amd64: gcc-6-base:i386 (6.2.1-5) breaks gcc-4.7-base (<< 4.7.3) and is installed. Version of gcc-4.7-base:amd64 to be configured is 4.7.2-5. gcc-6-base:amd64 (6.2.1-5) breaks gcc-4.7-base (<< 4.7.3) and is installed. Version of gcc-4.7-base:amd64 to be configured is 4.7.2-5.

dpkg: error processing package gcc-4.7-base:amd64 (--install): dependency problems - leaving unconfigured Errors were encountered while processing: gcc-4.7-base:amd64

The point, I can't remove gcc-6

  • 1
    Can you tell us why you need gcc 4.7? You could probably rebuild it from the Debian sources. This would be a "forward-port". – Faheem Mitha Dec 7 '16 at 9:26
  • I would like to run SeDuMi sedumi.ie.lehigh.edu/?page_id=58 – Smilia Dec 7 '16 at 9:28
  • you can also build it from vanilla sources - fr.mirror.babylon.network/gcc/releases/gcc-4.7.0/… – schaiba Dec 7 '16 at 9:42
  • You could also write to the authors for help (e.g. open a Github issue). I see they are providing binaries. Are you using an older version of gcc to compile because it is required for compatibility with your version of Matlab, because the provided binaries require 4.7 libraries, or for some other reason? – Faheem Mitha Dec 12 '16 at 20:59
  • because there binairies require 4.7... that's good idea I will do it – Smilia Dec 14 '16 at 1:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.